summaryrefslogtreecommitdiff
path: root/packages/openmoko-projects
diff options
context:
space:
mode:
Diffstat (limited to 'packages/openmoko-projects')
-rw-r--r--packages/openmoko-projects/assassin_svn.bb6
-rw-r--r--packages/openmoko-projects/diversity-daemon/.mtn2git_empty0
-rw-r--r--packages/openmoko-projects/diversity-daemon/no-xmmp.patch24
-rw-r--r--packages/openmoko-projects/diversity-daemon_svn.bb7
-rw-r--r--packages/openmoko-projects/diversity-maps-taipei_20080430.bb7
-rw-r--r--packages/openmoko-projects/diversity-maps.inc18
-rw-r--r--packages/openmoko-projects/diversity-nav_svn.bb6
-rw-r--r--packages/openmoko-projects/enlazar_svn.bb16
-rw-r--r--packages/openmoko-projects/illume-theme_svn.bb30
-rw-r--r--packages/openmoko-projects/illume/illume-fix-includes.patch70
-rw-r--r--packages/openmoko-projects/illume/keyboard.patch89
-rw-r--r--packages/openmoko-projects/illume_svn.bb20
12 files changed, 200 insertions, 93 deletions
diff --git a/packages/openmoko-projects/assassin_svn.bb b/packages/openmoko-projects/assassin_svn.bb
index 987d44070d..32c976df7a 100644
--- a/packages/openmoko-projects/assassin_svn.bb
+++ b/packages/openmoko-projects/assassin_svn.bb
@@ -1,9 +1,9 @@
DESCRIPTION = "Action GUI for Installer"
HOMEPAGE = "http://assassin.projects.openmoko.org/"
LICENSE = "GPL"
-DEPENDS = "dbus (>= 1.1.1) glib-2.0 e-wm packagekit etk edbus"
-PV = "0.2+svn${SRCREV}"
-PR = "r4"
+DEPENDS = "dbus (>= 1.1.1) glib-2.0 e-wm packagekit etk edbus eet"
+PV = "0.2+svnr${SRCREV}"
+PR = "r6"
SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=assassin;proto=https"
diff --git a/packages/openmoko-projects/diversity-daemon/.mtn2git_empty b/packages/openmoko-projects/diversity-daemon/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openmoko-projects/diversity-daemon/.mtn2git_empty
diff --git a/packages/openmoko-projects/diversity-daemon/no-xmmp.patch b/packages/openmoko-projects/diversity-daemon/no-xmmp.patch
new file mode 100644
index 0000000000..2065e97dce
--- /dev/null
+++ b/packages/openmoko-projects/diversity-daemon/no-xmmp.patch
@@ -0,0 +1,24 @@
+Index: diversity-xmpp-backend/Makefile.am
+===================================================================
+--- a/diversity-xmpp-backend/Makefile.am (revision 276)
++++ a/diversity-xmpp-backend/Makefile.am (working copy)
+@@ -1,3 +1,4 @@
++if HAVE_XMPP
+ INCLUDES = -I${top_srcdir}/include
+
+ AM_CPPFLAGS = \
+@@ -4,9 +5,7 @@
+ $(GLIB_CFLAGS) \
+ $(LM_CFLAGS)
+
+-if HAVE_XMPP
+ noinst_LTLIBRARIES = libdiversity-xmpp-backend.la
+-endif
+
+ noinst_HEADERS = diversity-xmpp-backend.h
+
+@@ -48,3 +47,4 @@
+
+ xmpp-marshal.h: xmpp-marshal.list
+ $(GLIB_GENMARSHAL) --prefix xmpp_marshal --header $< > $@
++endif
diff --git a/packages/openmoko-projects/diversity-daemon_svn.bb b/packages/openmoko-projects/diversity-daemon_svn.bb
index 8ffcdc5038..43c1d0a1b9 100644
--- a/packages/openmoko-projects/diversity-daemon_svn.bb
+++ b/packages/openmoko-projects/diversity-daemon_svn.bb
@@ -3,11 +3,12 @@ HOMEPAGE = "http://diversity.projects.openmoko.org/"
SECTION = "network/misc"
LICENSE = "GPL"
DEPENDS = "glib-2.0 dbus dbus-glib eds-dbus libjana curl"
-RDEPENDS_${PN} = "eds-dbus openmoko-dialer2"
+RDEPENDS_${PN} = "eds-dbus"
PV = "0.0+svnr${SRCREV}"
-PR = "r2"
+PR = "r3"
-SRC_URI = "svn://svn.projects.openmoko.org/svnroot/diversity/trunk;module=diversity-daemon;proto=https"
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/diversity/trunk;module=diversity-daemon;proto=https \
+ file://no-xmmp.patch;patch=1;minrev=276"
S = "${WORKDIR}/diversity-daemon"
inherit autotools pkgconfig
diff --git a/packages/openmoko-projects/diversity-maps-taipei_20080430.bb b/packages/openmoko-projects/diversity-maps-taipei_20080430.bb
new file mode 100644
index 0000000000..c882963fb2
--- /dev/null
+++ b/packages/openmoko-projects/diversity-maps-taipei_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r0"
+
+require diversity-maps.inc
+
+MAP_NAME = "Taipei"
+MAP_FN = "taipei.eet"
+MAP_VER = "${PV}"
diff --git a/packages/openmoko-projects/diversity-maps.inc b/packages/openmoko-projects/diversity-maps.inc
new file mode 100644
index 0000000000..9af5e95d95
--- /dev/null
+++ b/packages/openmoko-projects/diversity-maps.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Diversity Maps - ${MAP_NAME}"
+HOMEPAGE = "http://diversity.projects.openmoko.org/"
+SECTION = "network/misc"
+LICENSE = "Creative Commons Attribution-ShareAlike 2.0"
+
+SRC_URI = "http://people.openmoko.org/olv/diversity/${MAP_VER}/${MAP_FN}"
+
+MAP_DIR = "${datadir}/diversity-nav/maps"
+FILES_${PN} = "${MAP_DIR}/${MAP_FN}"
+
+PACKAGES = "${PN}"
+PACKAGE_ARCH = "all"
+PKG_TAGS_${PN} = "group::maps"
+
+do_install() {
+ install -d ${D}${MAP_DIR}
+ cp -f ${WORKDIR}/${MAP_FN} ${D}${MAP_DIR}
+}
diff --git a/packages/openmoko-projects/diversity-nav_svn.bb b/packages/openmoko-projects/diversity-nav_svn.bb
index 8d1af02d3a..9f839c5c5e 100644
--- a/packages/openmoko-projects/diversity-nav_svn.bb
+++ b/packages/openmoko-projects/diversity-nav_svn.bb
@@ -2,10 +2,10 @@ DESCRIPTION = "Diversity_nav - a GPS location based communicative application"
HOMEPAGE = "http://diversity.projects.openmoko.org/"
SECTION = "openmoko/applications"
LICENSE = "GPL"
-DEPENDS = "evas edje ecore edbus ewl"
-RDEPENDS_${PN} = "diversity-daemon ewl-themes"
+DEPENDS = "evas edje ecore edbus etk"
+RDEPENDS_${PN} = "diversity-daemon"
PV = "0.0.1+svnr${SRCREV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "svn://svn.projects.openmoko.org/svnroot/diversity/trunk;module=diversity-nav;proto=https"
diff --git a/packages/openmoko-projects/enlazar_svn.bb b/packages/openmoko-projects/enlazar_svn.bb
new file mode 100644
index 0000000000..38fdab4747
--- /dev/null
+++ b/packages/openmoko-projects/enlazar_svn.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Enlazar - Network part for Assasin"
+HOMEPAGE = "http://enlazar.projects.openmoko.org/"
+LICENSE = "GPL"
+DEPENDS = "evas edje ecore edbus"
+RDEPENDS = "networkmanager"
+PV = "0.1+svn${SRCREV}"
+PR = "r3"
+PE = "1"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/enlazar;module=trunk;proto=http"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = ""
diff --git a/packages/openmoko-projects/illume-theme_svn.bb b/packages/openmoko-projects/illume-theme_svn.bb
new file mode 100644
index 0000000000..b360d3b14a
--- /dev/null
+++ b/packages/openmoko-projects/illume-theme_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+
+PACKAGE_ARCH="all"
+PV = "0.0+svnr${SRCREV}"
+PR = "r4"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=illume;proto=https"
+S = "${WORKDIR}/illume"
+
+python do_unpack_append() {
+ bb.note("Unpacking to %s" % os.getcwd())
+ os.system("cd illume; tar -xz --no-same-owner -f misc-data/untar-me-from-root.tar.gz")
+}
+
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/config/
+
+ # Make illume the default profile
+ echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
+
+ install -m 0644 ${S}/misc-data/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ cp -pPR ${S}/.e/e/config/default ${D}${datadir}/enlightenment/data/config/illume
+}
diff --git a/packages/openmoko-projects/illume/illume-fix-includes.patch b/packages/openmoko-projects/illume/illume-fix-includes.patch
deleted file mode 100644
index 74418b31de..0000000000
--- a/packages/openmoko-projects/illume/illume-fix-includes.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-Index: src/e_mod_win.c
-===================================================================
---- src/e_mod_win.c (revision 14)
-+++ src/e_mod_win.c (working copy)
-@@ -1,4 +1,4 @@
--#include <e.h>
-+#include <enlightenment/e.h>
- #include "e_mod_win.h"
- #include "e_slipshelf.h"
- #include "e_slipwin.h"
-Index: src/e_kbd.c
-===================================================================
---- src/e_kbd.c (revision 14)
-+++ src/e_kbd.c (working copy)
-@@ -1,4 +1,4 @@
--#include <e.h>
-+#include <enlightenment/e.h>
- #include "e_kbd.h"
-
- /* internal calls */
-Index: src/e_slip.c
-===================================================================
---- src/e_slip.c (revision 14)
-+++ src/e_slip.c (working copy)
-@@ -1,4 +1,4 @@
--#include <e.h>
-+#include <enlightenment/e.h>
- #include "e_slip.h"
-
- EAPI int E_EVENT_SLIP_DEL = 0;
-Index: src/e_mod_layout.c
-===================================================================
---- src/e_mod_layout.c (revision 14)
-+++ src/e_mod_layout.c (working copy)
-@@ -1,4 +1,4 @@
--#include <e.h>
-+#include <enlightenment/e.h>
- #include "e_mod_main.h"
- #include "e_mod_layout.h"
-
-Index: src/e_mod_main.c
-===================================================================
---- src/e_mod_main.c (revision 14)
-+++ src/e_mod_main.c (working copy)
-@@ -1,4 +1,4 @@
--#include <e.h>
-+#include <enlightenment/e.h>
-
- #include "e_kbd.h"
- #include "e_slipshelf.h"
-Index: src/e_slipwin.c
-===================================================================
---- src/e_slipwin.c (revision 14)
-+++ src/e_slipwin.c (working copy)
-@@ -1,4 +1,4 @@
--#include <e.h>
-+#include <enlightenment/e.h>
- #include "e_slipwin.h"
-
- EAPI int E_EVENT_SLIPWIN_DEL = 0;
-Index: src/e_slipshelf.c
-===================================================================
---- src/e_slipshelf.c (revision 14)
-+++ src/e_slipshelf.c (working copy)
-@@ -1,4 +1,4 @@
--#include <e.h>
-+#include <enlightenment/e.h>
- #include "e_slipshelf.h"
-
- /* FIXME: break out gadcons for 2 swallow areas */
diff --git a/packages/openmoko-projects/illume/keyboard.patch b/packages/openmoko-projects/illume/keyboard.patch
new file mode 100644
index 0000000000..320e798a3e
--- /dev/null
+++ b/packages/openmoko-projects/illume/keyboard.patch
@@ -0,0 +1,89 @@
+Index: configure.in
+===================================================================
+--- configure.in (Revision 17)
++++ configure.in (Arbeitskopie)
+@@ -28,6 +28,9 @@
+ AC_SUBST(LOCALEDIR, "${localedir}")
+ AC_DEFINE_UNQUOTED(LOCALEDIR, "${localedir}", "Module Locale Directory")
+
++keyboarddir="${datarootdir}/${PACKAGE}/keyboard"
++AC_SUBST(keyboarddir)
++
+ #
+ # Check EFL Libs
+ #
+Index: src/e_kbd.c
+===================================================================
+--- src/e_kbd.c (Revision 17)
++++ src/e_kbd.c (Arbeitskopie)
+@@ -57,6 +57,7 @@
+
+ static int _e_kbd_config_parse(E_Kbd *kbd, const char *config);
+ static Evas_Object *_theme_obj_new(Evas *e, const char *custom_dir, const char *group);
++static char* _e_kbd_get_default_path(void);
+
+ /* state */
+
+@@ -470,7 +471,7 @@
+ edje_object_part_swallow(kbd->base_obj, "e.swallow.content", o);
+ evas_object_show(o);
+ kbd->layout_obj = o;
+- _e_kbd_config_parse(kbd, "/home/raster/work/illume/default.kbd");
++ _e_kbd_config_parse(kbd, _e_kbd_get_default_path());
+ _e_kbd_layout_build(kbd);
+
+ edje_object_size_min_calc(kbd->base_obj, &mw, &mh);
+@@ -744,3 +745,26 @@
+ }
+ return o;
+ }
++
++/*
++ * Return the to be used keyboard file
++ */
++static char *
++_e_kbd_get_default_path()
++{
++ static char *buf = 0;
++
++ if (getenv("ILLUME_KEYBOARD_DIR"))
++ {
++ if (!buf)
++ {
++ buf = (char*)malloc(sizeof(char)*PATH_MAX);
++ }
++
++ snprintf(buf, PATH_MAX, "%s/default.kbd", getenv("ILLUME_KEYBOARD_DIR"));
++ return buf;
++ }
++
++
++ return KEYBOARDDIR"/default.kbd";
++}
+Index: src/Makefile.am
+===================================================================
+--- src/Makefile.am (Revision 17)
++++ src/Makefile.am (Arbeitskopie)
+@@ -1,6 +1,8 @@
+ ACLOCAL_AMFLAGS = -I m4
+ MAINTAINERCLEANFILES = Makefile.in
+
++AM_CPPFLAGS = -DKEYBOARDDIR=\"$(keyboarddir)\"
++
+ INCLUDES = -I. \
+ -I$(top_srcdir) \
+ @e_cflags@
+Index: Makefile.am
+===================================================================
+--- Makefile.am (Revision 17)
++++ Makefile.am (Arbeitskopie)
+@@ -14,6 +14,9 @@
+ files_DATA = module.desktop \
+ e-module-illume.edj \
+ illume.edj
++
++keybddir = $(keyboarddir)
++keybd_DATA = default.kbd
+
+ EXTRA_DIST = $(files_DATA) \
+ illume.edc \
diff --git a/packages/openmoko-projects/illume_svn.bb b/packages/openmoko-projects/illume_svn.bb
index f93108dca4..5136240568 100644
--- a/packages/openmoko-projects/illume_svn.bb
+++ b/packages/openmoko-projects/illume_svn.bb
@@ -1,14 +1,13 @@
DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
HOMEPAGE = "http://illume.projects.openmoko.org/"
LICENSE = "MIT/BSD"
-
DEPENDS = "e-wm eet evas ecore edje embryo efreet edbus edje-native embryo-native"
-
+RRECOMMENDS = "wamerican"
PV = "0.0+svnr${SRCREV}"
-PR = "r1"
+PR = "r3"
SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=${PN};proto=https \
- file://illume-fix-includes.patch;patch=1;pnum=0;minrev=14"
+ file://keyboard.patch;patch=1;pnum=0;minrev=17;maxrev=20"
S = "${WORKDIR}/${PN}"
@@ -16,18 +15,11 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
- --enable-simple-x11 \
+ --enable-simple-x11 \
--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
-export CFLAGS += "-DE_TYPEDEFS=1"
-
-do_configure_append() {
- find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
- find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
-}
-
FILES_${PN} = "${libdir}/enlightenment/modules/*/*.edj \
${libdir}/enlightenment/modules/*/*.desktop \
- ${libdir}/enlightenment/modules/*/*/*"
-
+ ${libdir}/enlightenment/modules/*/*/* \
+ ${datadir}/${PN} "
FILES_${PN}-dbg += "${libdir}/enlightenment/modules/*/*/.debug/"