summaryrefslogtreecommitdiff
path: root/packages/openmoko-projects/illume-theme_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/openmoko-projects/illume-theme_svn.bb')
-rw-r--r--packages/openmoko-projects/illume-theme_svn.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/openmoko-projects/illume-theme_svn.bb b/packages/openmoko-projects/illume-theme_svn.bb
new file mode 100644
index 0000000000..b360d3b14a
--- /dev/null
+++ b/packages/openmoko-projects/illume-theme_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+
+PACKAGE_ARCH="all"
+PV = "0.0+svnr${SRCREV}"
+PR = "r4"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=illume;proto=https"
+S = "${WORKDIR}/illume"
+
+python do_unpack_append() {
+ bb.note("Unpacking to %s" % os.getcwd())
+ os.system("cd illume; tar -xz --no-same-owner -f misc-data/untar-me-from-root.tar.gz")
+}
+
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/config/
+
+ # Make illume the default profile
+ echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
+
+ install -m 0644 ${S}/misc-data/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ cp -pPR ${S}/.e/e/config/default ${D}${datadir}/enlightenment/data/config/illume
+}