summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrii Pientsov <andrii.pientsov@globallogic.com>2021-12-23 14:46:29 +0200
committerAndrii Pientsov <andrii.pientsov@globallogic.com>2021-12-23 14:46:29 +0200
commitbcfa52043aaef910f0adb11f2ba12a39ef4a890e (patch)
tree0059aa119cc15e1cba47cb67de16468c3f2aff23
parent2071cfc761d785ee4900ab99893fbc31a1e01d5a (diff)
downloadmeta-multitech-bcfa52043aaef910f0adb11f2ba12a39ef4a890e.tar.gz
meta-multitech-bcfa52043aaef910f0adb11f2ba12a39ef4a890e.tar.bz2
meta-multitech-bcfa52043aaef910f0adb11f2ba12a39ef4a890e.zip
Remove unnecessary patches for mts-io. Switch mtac-lora from 1.1.5 to 1.1.9.
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.1.1.bb1
-rw-r--r--recipes-bsp/multitech/mtac-lora_1.1.9.bb (renamed from recipes-bsp/multitech/mtac-lora_1.1.5.bb)0
-rw-r--r--recipes-bsp/multitech/mts-io/MTCDT-0.2.patch71
-rw-r--r--recipes-bsp/multitech/mts-io/ioport-gpio-expand.patch28
4 files changed, 0 insertions, 100 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.1.1.bb b/recipes-bsp/multitech/mt-dt-overlay_1.1.1.bb
index 0458c76..09c8f4a 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.1.1.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.1.1.bb
@@ -13,7 +13,6 @@ DEPENDS = "dtc-native linux-at91"
RDEPENDS_${PN} = "bash"
-# For now, just mtcap
COMPATIBLE_MACHINE = "(mtcap|mtrv1|mtcdt)"
# By using an overlay, we should be able to support multiple pinouts
diff --git a/recipes-bsp/multitech/mtac-lora_1.1.5.bb b/recipes-bsp/multitech/mtac-lora_1.1.9.bb
index 447eb6e..447eb6e 100644
--- a/recipes-bsp/multitech/mtac-lora_1.1.5.bb
+++ b/recipes-bsp/multitech/mtac-lora_1.1.9.bb
diff --git a/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch b/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch
deleted file mode 100644
index 77c7457..0000000
--- a/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 7c25e08..27696b9 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,4 +1,4 @@
--AC_INIT([mts-io], [4.7.2])
-+AC_INIT([mts-io], [4.7.3])
- AC_CONFIG_SRCDIR([util/mts_util_lora2_reset.c])
- AM_INIT_AUTOMAKE
- AM_CONFIG_HEADER([config.h])
-diff --git a/io-module/mts-io.c b/io-module/mts-io.c
-index ed0cb49..6fad83f 100644
---- a/io-module/mts-io.c
-+++ b/io-module/mts-io.c
-@@ -80,6 +80,13 @@ MODULE_DEVICE_TABLE(of, mts_io_dt_ids);
- /* on-board EEPROM */
- static struct mts_id_eeprom_layout id_eeprom;
-
-+// Allow other modules to query the hardware version
-+const char *mts_get_hw_version(void)
-+{
-+ return id_eeprom.hw_version;
-+}
-+EXPORT_SYMBOL(mts_get_hw_version);
-+
- #include "adc.c"
-
- static int mts_io_probe(struct platform_device *pdev)
-@@ -544,6 +551,9 @@ static DEVICE_ATTR_MTS(dev_attr_led_d_gpio, "led-d",
- static DEVICE_ATTR_MTS(dev_attr_led_e_gpio, "led-e",
- mts_attr_show_gpio_pin, mts_attr_store_gpio_pin);
-
-+
-+
-+
- /* eeprom info */
- static ssize_t mts_attr_show_product_info(struct device *dev,
- struct device_attribute *attr,
-diff --git a/io-module/mts_io.h b/io-module/mts_io.h
-index 2c4b7b6..4f46804 100644
---- a/io-module/mts_io.h
-+++ b/io-module/mts_io.h
-@@ -50,6 +50,7 @@ struct gpio_pin {
- };
-
- extern int mts_has_radio(const char *product_id, size_t len);
-+extern const char *mts_get_hw_version(void);
-
- #endif /* __MTS_IO_H */
-
-diff --git a/io-module/mts_io_module.h b/io-module/mts_io_module.h
-index eca15a3..83a2994 100644
---- a/io-module/mts_io_module.h
-+++ b/io-module/mts_io_module.h
-@@ -5,7 +5,7 @@
- * MTAC cards.
- */
-
--#define DRIVER_VERSION "v4.7.2"
-+#define DRIVER_VERSION "v4.7.3"
- #define DRIVER_AUTHOR "Multitech Systems"
- #define DRIVER_DESC "MTS-IO Controller"
- #define DRIVER_NAME "mts-io"
-@@ -36,6 +36,7 @@
- #define HW_VERSION_MTRE "MTRE-0.0"
- #define HW_VERSION_MTCDT_0_0 "MTCDT-0.0" // No GPS or WiFi Capability
- #define HW_VERSION_MTCDT_0_1 "MTCDT-0.1" // Conduit refresh with GPS and WiFi possible
-+#define HW_VERSION_MTCDT_0_2 "MTCDT-0.2" // FTDI with no multi-drop serial support
- #define HW_VERSION_MTCDTIP_0_0 "MTCDTIP-0.0"
- #define HW_VERSION_MTCDTIPHP_0_0 "MTCDTIPHP-0.0" // Also known as LoRa 2.1
- #define HW_VERSION_MTCAP_0_0 "MTCAP-0.0"
diff --git a/recipes-bsp/multitech/mts-io/ioport-gpio-expand.patch b/recipes-bsp/multitech/mts-io/ioport-gpio-expand.patch
deleted file mode 100644
index c413d21..0000000
--- a/recipes-bsp/multitech/mts-io/ioport-gpio-expand.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/io-module/at91gpio.h b/io-module/at91gpio.h
-index c2f8a77..d6328f1 100644
---- a/io-module/at91gpio.h
-+++ b/io-module/at91gpio.h
-@@ -179,4 +179,23 @@
- #define AT91_PIN_PE30 (0x80 + 30)
- #define AT91_PIN_PE31 (0x80 + 31)
-
-+// MTCDT-0.2 I2C I/O Port expanders
-+#define PCA9557_0_IO0 (0xa0 + 0)
-+#define PCA9557_0_IO1 (0xa0 + 1)
-+#define PCA9557_0_IO2 (0xa0 + 2)
-+#define PCA9557_0_IO3 (0xa0 + 3)
-+#define PCA9557_0_IO4 (0xa0 + 4)
-+#define PCA9557_0_IO5 (0xa0 + 5)
-+#define PCA9557_0_IO6 (0xa0 + 6)
-+#define PCA9557_0_IO7 (0xa0 + 7)
-+
-+#define PCA9557_1_IO0 (0xa8 + 0)
-+#define PCA9557_1_IO1 (0xa8 + 1)
-+#define PCA9557_1_IO2 (0xa8 + 2)
-+#define PCA9557_1_IO3 (0xa8 + 3)
-+#define PCA9557_1_IO4 (0xa8 + 4)
-+#define PCA9557_1_IO5 (0xa8 + 5)
-+#define PCA9557_1_IO6 (0xa8 + 6)
-+#define PCA9557_1_IO7 (0xa8 + 7)
-+
- #endif