summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/multitech/mts-io/MTCDT-0.2.patch')
-rw-r--r--recipes-bsp/multitech/mts-io/MTCDT-0.2.patch71
1 files changed, 0 insertions, 71 deletions
diff --git a/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch b/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch
deleted file mode 100644
index 77c7457..0000000
--- a/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 7c25e08..27696b9 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,4 +1,4 @@
--AC_INIT([mts-io], [4.7.2])
-+AC_INIT([mts-io], [4.7.3])
- AC_CONFIG_SRCDIR([util/mts_util_lora2_reset.c])
- AM_INIT_AUTOMAKE
- AM_CONFIG_HEADER([config.h])
-diff --git a/io-module/mts-io.c b/io-module/mts-io.c
-index ed0cb49..6fad83f 100644
---- a/io-module/mts-io.c
-+++ b/io-module/mts-io.c
-@@ -80,6 +80,13 @@ MODULE_DEVICE_TABLE(of, mts_io_dt_ids);
- /* on-board EEPROM */
- static struct mts_id_eeprom_layout id_eeprom;
-
-+// Allow other modules to query the hardware version
-+const char *mts_get_hw_version(void)
-+{
-+ return id_eeprom.hw_version;
-+}
-+EXPORT_SYMBOL(mts_get_hw_version);
-+
- #include "adc.c"
-
- static int mts_io_probe(struct platform_device *pdev)
-@@ -544,6 +551,9 @@ static DEVICE_ATTR_MTS(dev_attr_led_d_gpio, "led-d",
- static DEVICE_ATTR_MTS(dev_attr_led_e_gpio, "led-e",
- mts_attr_show_gpio_pin, mts_attr_store_gpio_pin);
-
-+
-+
-+
- /* eeprom info */
- static ssize_t mts_attr_show_product_info(struct device *dev,
- struct device_attribute *attr,
-diff --git a/io-module/mts_io.h b/io-module/mts_io.h
-index 2c4b7b6..4f46804 100644
---- a/io-module/mts_io.h
-+++ b/io-module/mts_io.h
-@@ -50,6 +50,7 @@ struct gpio_pin {
- };
-
- extern int mts_has_radio(const char *product_id, size_t len);
-+extern const char *mts_get_hw_version(void);
-
- #endif /* __MTS_IO_H */
-
-diff --git a/io-module/mts_io_module.h b/io-module/mts_io_module.h
-index eca15a3..83a2994 100644
---- a/io-module/mts_io_module.h
-+++ b/io-module/mts_io_module.h
-@@ -5,7 +5,7 @@
- * MTAC cards.
- */
-
--#define DRIVER_VERSION "v4.7.2"
-+#define DRIVER_VERSION "v4.7.3"
- #define DRIVER_AUTHOR "Multitech Systems"
- #define DRIVER_DESC "MTS-IO Controller"
- #define DRIVER_NAME "mts-io"
-@@ -36,6 +36,7 @@
- #define HW_VERSION_MTRE "MTRE-0.0"
- #define HW_VERSION_MTCDT_0_0 "MTCDT-0.0" // No GPS or WiFi Capability
- #define HW_VERSION_MTCDT_0_1 "MTCDT-0.1" // Conduit refresh with GPS and WiFi possible
-+#define HW_VERSION_MTCDT_0_2 "MTCDT-0.2" // FTDI with no multi-drop serial support
- #define HW_VERSION_MTCDTIP_0_0 "MTCDTIP-0.0"
- #define HW_VERSION_MTCDTIPHP_0_0 "MTCDTIPHP-0.0" // Also known as LoRa 2.1
- #define HW_VERSION_MTCAP_0_0 "MTCAP-0.0"