summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-core/udev/eudev/cellular_radios.sh5
-rw-r--r--recipes-core/udev/eudev_%.bbappend2
2 files changed, 6 insertions, 1 deletions
diff --git a/recipes-core/udev/eudev/cellular_radios.sh b/recipes-core/udev/eudev/cellular_radios.sh
index cb9258b..ee0ba2e 100644
--- a/recipes-core/udev/eudev/cellular_radios.sh
+++ b/recipes-core/udev/eudev/cellular_radios.sh
@@ -13,3 +13,8 @@ if [[ -f $READYFILE ]] ; then
echo 1 >$READYFILE
fi
+# Disable echo for modem_at1. Mandatory for Sequans
+STTY_PATH=/bin/stty
+if [[ -x "$STTY_PATH" && -n "$DEVNAME" ]]; then
+ "$STTY_PATH" -echo -echoe -echok -echoctl -echoke -F "$DEVNAME"
+fi
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index 5966524..f781c83 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
RDEPENDS_${PN} += "bash"
-PR .= ".mlinux9"
+PR .= ".mlinux10"
# add custom rules for persistent modem device names
SRC_URI += "file://cellular_radios.rules \