summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2023-02-10 14:42:47 +0200
committerJohn Klug <john.klug@multitech.com>2023-02-10 09:23:59 -0600
commitcfcae699e62a9272d6dc1529367a0fea2485ba5d (patch)
tree7cf911edcd85daea7d99c87a3d52d3c596032ca3
parent0e5564fedb582bd714b8166eac0219701577800b (diff)
downloadmeta-mlinux-cfcae699e62a9272d6dc1529367a0fea2485ba5d.tar.gz
meta-mlinux-cfcae699e62a9272d6dc1529367a0fea2485ba5d.tar.bz2
meta-mlinux-cfcae699e62a9272d6dc1529367a0fea2485ba5d.zip
[GP-1733] Disable echo on /dev/modem_at1
Disable the "echo" terminos option for /dev/modem_at1. This change is mandatory for Sequans, becase the Sequans radios do not tolerate garbage in their input.
-rw-r--r--recipes-core/udev/eudev/cellular_radios.sh5
-rw-r--r--recipes-core/udev/eudev_%.bbappend2
2 files changed, 6 insertions, 1 deletions
diff --git a/recipes-core/udev/eudev/cellular_radios.sh b/recipes-core/udev/eudev/cellular_radios.sh
index cb9258b..ee0ba2e 100644
--- a/recipes-core/udev/eudev/cellular_radios.sh
+++ b/recipes-core/udev/eudev/cellular_radios.sh
@@ -13,3 +13,8 @@ if [[ -f $READYFILE ]] ; then
echo 1 >$READYFILE
fi
+# Disable echo for modem_at1. Mandatory for Sequans
+STTY_PATH=/bin/stty
+if [[ -x "$STTY_PATH" && -n "$DEVNAME" ]]; then
+ "$STTY_PATH" -echo -echoe -echok -echoctl -echoke -F "$DEVNAME"
+fi
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index 5966524..f781c83 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
RDEPENDS_${PN} += "bash"
-PR .= ".mlinux9"
+PR .= ".mlinux10"
# add custom rules for persistent modem device names
SRC_URI += "file://cellular_radios.rules \