summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2022-08-31 15:20:11 +0300
committerJohn Klug <john.klug@multitech.com>2022-11-16 17:38:50 -0600
commitf4d0c5cbfe332d5932827709d1d4ca96d1968036 (patch)
tree85a29e9865bbfc415a549d4d14732a50f81d28f0
parent2bcb714dd8d3f60989e663b871b726006e85de06 (diff)
downloadmeta-mlinux-f4d0c5cbfe332d5932827709d1d4ca96d1968036.tar.gz
meta-mlinux-f4d0c5cbfe332d5932827709d1d4ca96d1968036.tar.bz2
meta-mlinux-f4d0c5cbfe332d5932827709d1d4ca96d1968036.zip
Manufacturing - MTCDT - Create mountpoints at build time
fstab can't mount the partitions on the first boot if the mountpoint does not exist. Create the mountpoints at build time so that fstab can mount the partitions on the first try. Required for the next commits with customizations for SDMFG. Also: Having the mountpoints pre-created is beneficial for devices with read-only root file systems (like MTR with mPower). This solution is actually ported from mPower: https://gitlab.multitech.net/multitech/meta-mts-device/blob/0f8b5467c662a1be59a2ee5adc91b7c99aa87497/recipes-core/base-files/base-files_3.0.14.bbappend.
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
index 74fb040..c4b642d 100644
--- a/recipes-core/base-files/base-files_3.0.14.bbappend
+++ b/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -1,9 +1,14 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PR = "m3"
+PR = "m4"
CONFFILES_${PN}_remove = "${sysconfdir}/fstab"
FILES_${PN}_remove = "${sysconfdir}/fstab"
+# Create folders for generic mountpoints at build time
+dirs755_append = " /var/config \
+ /var/oem \
+ "
+
do_install_append() {
if [ -d ${D}/media ] ; then
rmdir ${D}/media # So the next line does not nest the media link inside of media