summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarsh Sharma <harsh.sharma@multitech.com>2022-11-16 10:27:04 -0600
committerHarsh Sharma <harsh.sharma@multitech.com>2022-11-16 10:27:04 -0600
commit2bcb714dd8d3f60989e663b871b726006e85de06 (patch)
treeba1ae6be7c8554c8850a82c3d93f0b32792c5180
parent2c2b0bd02c31fde0652cd42b51bc82cbfda1ef4a (diff)
parent127aa9bbd8e2c750b9eca734678527d7285abbb4 (diff)
downloadmeta-mlinux-2bcb714dd8d3f60989e663b871b726006e85de06.tar.gz
meta-mlinux-2bcb714dd8d3f60989e663b871b726006e85de06.tar.bz2
meta-mlinux-2bcb714dd8d3f60989e663b871b726006e85de06.zip
Merge branch 'sk/golang-docker-fixes' into 6
-rw-r--r--recipes-containers/containerd/containerd-docker_%.bbappend6
-rw-r--r--recipes-containers/containerd/containerd-opencontainers_%.bbappend6
-rw-r--r--recipes-containers/docker/docker-moby.bbappend6
-rw-r--r--recipes-containers/runc/runc-docker_%.bbappend6
-rw-r--r--recipes-containers/runc/runc-opencontainers_%.bbappend6
5 files changed, 30 insertions, 0 deletions
diff --git a/recipes-containers/containerd/containerd-docker_%.bbappend b/recipes-containers/containerd/containerd-docker_%.bbappend
new file mode 100644
index 0000000..bfedff1
--- /dev/null
+++ b/recipes-containers/containerd/containerd-docker_%.bbappend
@@ -0,0 +1,6 @@
+# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
+# version 3.3 and newer.
+# Fix in the upstream Yocto: https://git.yoctoproject.org/meta-virtualization/commit/recipes-containers/containerd/containerd-opencontainers_git.bb?h=hardknott&id=8597d4e3a973ac7e78483fb3ab0e19dbcc681913.
+do_compile_prepend() {
+ export GO111MODULE=off
+}
diff --git a/recipes-containers/containerd/containerd-opencontainers_%.bbappend b/recipes-containers/containerd/containerd-opencontainers_%.bbappend
new file mode 100644
index 0000000..bfedff1
--- /dev/null
+++ b/recipes-containers/containerd/containerd-opencontainers_%.bbappend
@@ -0,0 +1,6 @@
+# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
+# version 3.3 and newer.
+# Fix in the upstream Yocto: https://git.yoctoproject.org/meta-virtualization/commit/recipes-containers/containerd/containerd-opencontainers_git.bb?h=hardknott&id=8597d4e3a973ac7e78483fb3ab0e19dbcc681913.
+do_compile_prepend() {
+ export GO111MODULE=off
+}
diff --git a/recipes-containers/docker/docker-moby.bbappend b/recipes-containers/docker/docker-moby.bbappend
new file mode 100644
index 0000000..fba7110
--- /dev/null
+++ b/recipes-containers/docker/docker-moby.bbappend
@@ -0,0 +1,6 @@
+# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
+# version 3.3 and newer.
+# Fix in the upstream Yocto: https://git.yoctoproject.org/meta-virtualization/commit/recipes-containers/docker/docker-moby.bb?h=hardknott&id=dc1713bec31ecd52a9715fd528253b26140f69d3
+do_compile_prepend() {
+ export GO111MODULE=off
+}
diff --git a/recipes-containers/runc/runc-docker_%.bbappend b/recipes-containers/runc/runc-docker_%.bbappend
new file mode 100644
index 0000000..5755da5
--- /dev/null
+++ b/recipes-containers/runc/runc-docker_%.bbappend
@@ -0,0 +1,6 @@
+# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
+# version 3.3 and newer. The new versions of `runc` do NOT require this
+# hack, they should work properly with `GO111MODULE` and Golang 1.16.x:
+do_compile_prepend() {
+ export GO111MODULE=off
+}
diff --git a/recipes-containers/runc/runc-opencontainers_%.bbappend b/recipes-containers/runc/runc-opencontainers_%.bbappend
new file mode 100644
index 0000000..5755da5
--- /dev/null
+++ b/recipes-containers/runc/runc-opencontainers_%.bbappend
@@ -0,0 +1,6 @@
+# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
+# version 3.3 and newer. The new versions of `runc` do NOT require this
+# hack, they should work properly with `GO111MODULE` and Golang 1.16.x:
+do_compile_prepend() {
+ export GO111MODULE=off
+}