summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2022-11-17 10:43:06 +0200
committerJohn Klug <john.klug@multitech.com>2022-11-17 08:50:16 -0600
commit09cbb08cef135a98f0b55a68291773ae80d1c781 (patch)
treeae6e2a279c854c92333053e70a5e56b42259337a
parentdd735635a7eba6de2220f597316fe354bbb933c1 (diff)
downloadmeta-mlinux-09cbb08cef135a98f0b55a68291773ae80d1c781.tar.gz
meta-mlinux-09cbb08cef135a98f0b55a68291773ae80d1c781.tar.bz2
meta-mlinux-09cbb08cef135a98f0b55a68291773ae80d1c781.zip
Revert "Docker: Fixed builds after updating to Golang 1.16.x"
This reverts commit 127aa9bbd8e2c750b9eca734678527d7285abbb4. Reverted the commit to prevent build issues on Atmel. Atmel devices have no "meta-virtualization" layer, no docker recipes and hence bbappends for such recipes cause the build issues. bbappends moved to meta-mlinux-ti.
-rw-r--r--recipes-containers/containerd/containerd-docker_%.bbappend6
-rw-r--r--recipes-containers/containerd/containerd-opencontainers_%.bbappend6
-rw-r--r--recipes-containers/docker/docker-moby.bbappend6
-rw-r--r--recipes-containers/runc/runc-docker_%.bbappend6
-rw-r--r--recipes-containers/runc/runc-opencontainers_%.bbappend6
5 files changed, 0 insertions, 30 deletions
diff --git a/recipes-containers/containerd/containerd-docker_%.bbappend b/recipes-containers/containerd/containerd-docker_%.bbappend
deleted file mode 100644
index bfedff1..0000000
--- a/recipes-containers/containerd/containerd-docker_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
-# version 3.3 and newer.
-# Fix in the upstream Yocto: https://git.yoctoproject.org/meta-virtualization/commit/recipes-containers/containerd/containerd-opencontainers_git.bb?h=hardknott&id=8597d4e3a973ac7e78483fb3ab0e19dbcc681913.
-do_compile_prepend() {
- export GO111MODULE=off
-}
diff --git a/recipes-containers/containerd/containerd-opencontainers_%.bbappend b/recipes-containers/containerd/containerd-opencontainers_%.bbappend
deleted file mode 100644
index bfedff1..0000000
--- a/recipes-containers/containerd/containerd-opencontainers_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
-# version 3.3 and newer.
-# Fix in the upstream Yocto: https://git.yoctoproject.org/meta-virtualization/commit/recipes-containers/containerd/containerd-opencontainers_git.bb?h=hardknott&id=8597d4e3a973ac7e78483fb3ab0e19dbcc681913.
-do_compile_prepend() {
- export GO111MODULE=off
-}
diff --git a/recipes-containers/docker/docker-moby.bbappend b/recipes-containers/docker/docker-moby.bbappend
deleted file mode 100644
index fba7110..0000000
--- a/recipes-containers/docker/docker-moby.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
-# version 3.3 and newer.
-# Fix in the upstream Yocto: https://git.yoctoproject.org/meta-virtualization/commit/recipes-containers/docker/docker-moby.bb?h=hardknott&id=dc1713bec31ecd52a9715fd528253b26140f69d3
-do_compile_prepend() {
- export GO111MODULE=off
-}
diff --git a/recipes-containers/runc/runc-docker_%.bbappend b/recipes-containers/runc/runc-docker_%.bbappend
deleted file mode 100644
index 5755da5..0000000
--- a/recipes-containers/runc/runc-docker_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
-# version 3.3 and newer. The new versions of `runc` do NOT require this
-# hack, they should work properly with `GO111MODULE` and Golang 1.16.x:
-do_compile_prepend() {
- export GO111MODULE=off
-}
diff --git a/recipes-containers/runc/runc-opencontainers_%.bbappend b/recipes-containers/runc/runc-opencontainers_%.bbappend
deleted file mode 100644
index 5755da5..0000000
--- a/recipes-containers/runc/runc-opencontainers_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Fix build issues with Go version 1.16.x. Remove this bbappend in Yocto
-# version 3.3 and newer. The new versions of `runc` do NOT require this
-# hack, they should work properly with `GO111MODULE` and Golang 1.16.x:
-do_compile_prepend() {
- export GO111MODULE=off
-}