summaryrefslogtreecommitdiff
path: root/recipes/xbmc/libcdio_0.81.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xbmc/libcdio_0.81.bb')
-rw-r--r--recipes/xbmc/libcdio_0.81.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/xbmc/libcdio_0.81.bb b/recipes/xbmc/libcdio_0.81.bb
new file mode 100644
index 0000000000..e900336bb2
--- /dev/null
+++ b/recipes/xbmc/libcdio_0.81.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
+LICENSE = "GPL"
+
+SRC_URI = "http://ftp.gnu.org/gnu/libcdio/libcdio-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = " ac_cv_member_struct_tm_tm_gmtoff=no"
+
+FILES_${PN} = "${bindir}/*"
+
+python populate_packages_prepend () {
+ glibdir = bb.data.expand('${libdir}', d)
+ do_split_packages(d, glibdir, '^lib(.*)\.so\.*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True)
+}
+
+
+