summaryrefslogtreecommitdiff
path: root/recipes/watchdog/watchdog_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/watchdog/watchdog_5.4.bb')
-rw-r--r--recipes/watchdog/watchdog_5.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/watchdog/watchdog_5.4.bb b/recipes/watchdog/watchdog_5.4.bb
new file mode 100644
index 0000000000..ec4cea42a7
--- /dev/null
+++ b/recipes/watchdog/watchdog_5.4.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "System watchdog daemon"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${PN}-${PV}.tar.gz \
+ file://init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "watchdog"
+INITSCRIPT_PARAMS = "defaults 10"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/watchdog
+}
+