summaryrefslogtreecommitdiff
path: root/recipes/ti/ti-cs1-omap3530_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/ti-cs1-omap3530_1.0.1.bb')
-rw-r--r--recipes/ti/ti-cs1-omap3530_1.0.1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/ti/ti-cs1-omap3530_1.0.1.bb b/recipes/ti/ti-cs1-omap3530_1.0.1.bb
new file mode 100644
index 0000000000..61d5406305
--- /dev/null
+++ b/recipes/ti/ti-cs1-omap3530_1.0.1.bb
@@ -0,0 +1,53 @@
+require ti-codec.inc
+require ti-cs1-omap3530.inc
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/dvsdk/DVSDK_3_00/latest//exports/cs1omap3530_setuplinux_1_00_01.bin"
+
+# Specify names of the InstallJammer binary file and the tarball it extracts
+BINFILE = "cs1omap3530_setuplinux_1_00_01.bin"
+
+S = "${WORKDIR}/dvsdk_3_00_00_40/cs1omap3530_1_00_01"
+
+DEPENDS="ti-codec-engine ti-dsplink-module"
+
+export CODEGEN_INSTALL_DIR
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "101"
+PR = "r4"
+
+do_compile() {
+
+ make CE_INSTALL_DIR=${CE_INSTALL_DIR} \
+ FC_INSTALL_DIR=${FC_INSTALL_DIR} \
+ LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
+ CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
+ LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
+ BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
+ CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
+ XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
+ CODEC_INSTALL_DIR="${S}" \
+ XDCARGS="prod" \
+ clean
+
+ make CE_INSTALL_DIR=${CE_INSTALL_DIR} \
+ FC_INSTALL_DIR=${FC_INSTALL_DIR} \
+ LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
+ CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
+ LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
+ BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
+ CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
+ XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
+ CODEC_INSTALL_DIR="${S}" \
+ XDCARGS="prod" \
+}
+
+do_install () {
+ install -d ${D}/${installdir}/codec-combo
+ cd ${S}
+ for file in `find . -name *.x64P`; do
+ cp ${file} ${D}/${installdir}/codec-combo
+ done
+}
+
+