summaryrefslogtreecommitdiff
path: root/recipes/ti/matrix-gui_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/matrix-gui_svn.bb')
-rw-r--r--recipes/ti/matrix-gui_svn.bb29
1 files changed, 24 insertions, 5 deletions
diff --git a/recipes/ti/matrix-gui_svn.bb b/recipes/ti/matrix-gui_svn.bb
index 794ffbc10a..6042d966b8 100644
--- a/recipes/ti/matrix-gui_svn.bb
+++ b/recipes/ti/matrix-gui_svn.bb
@@ -1,15 +1,15 @@
DESCRIPTION = "Matrix GUI"
HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
-LICENSE = "TI"
+LICENSE = "Apache"
SECTION = "multimedia"
PRIORITY = "optional"
-SRCREV = "52"
+SRCREV = "54"
PV = "1.0"
-PR = "r1+svnr${SRCPV}"
+PR = "r4+svnr${SRCPV}"
SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' \
- file://init \
+ file://init \
"
S = "${WORKDIR}/trunk"
@@ -19,13 +19,32 @@ INITSCRIPT_PARAMS = "defaults 99"
inherit qt4e update-rc.d
+MATRIX_EXTRA_BINS = " \
+ memInfo \
+ networkSettings \
+ runOGLES2Coverflow \
+ runOGLES2Shaders \
+ runOGLESChameleonMan \
+ runOGLESVase \
+ setopp1 \
+ setopp2 \
+ setopp3 \
+ setopp4 \
+ standby \
+ sysSettings \
+ taskInfo \
+"
+
do_install() {
install -d ${D}/${bindir}
install -m 0755 ${S}/matrix_gui ${D}/${bindir}
+ for i in ${MATRIX_EXTRA_BINS}; do
+ install -m 0755 ${S}/bin/${i} ${D}/${bindir}
+ done
install -d ${D}/${datadir}/matrix/html
install -m 0644 ${S}/*.html ${D}/${datadir}/matrix/html/
install -d ${D}/${datadir}/matrix/images
- install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
+ install -m 0644 ${S}/images/*.bmp ${D}/${datadir}/matrix/images/
install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
install -d ${D}${sysconfdir}/init.d/
install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-gui