summaryrefslogtreecommitdiff
path: root/recipes/skippy/skippy-xd_0.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/skippy/skippy-xd_0.5.0.bb')
-rw-r--r--recipes/skippy/skippy-xd_0.5.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/skippy/skippy-xd_0.5.0.bb b/recipes/skippy/skippy-xd_0.5.0.bb
new file mode 100644
index 0000000000..c5ed177aa6
--- /dev/null
+++ b/recipes/skippy/skippy-xd_0.5.0.bb
@@ -0,0 +1,18 @@
+LICENSE = "GPLV2"
+DESCRIPTION = "Skippy is a full-screen task-switcher for X11."
+SECTION = "x11"
+DEPENDS = "virtual/xserver libxdamage libxcomposite"
+
+inherit pkgconfig
+
+SRC_URI = "http://thegraveyard.org/files/${PN}-${PV}.tar.bz2 \
+ file://fix-makefile.patch;patch=1 \
+ file://event_base.patch;patch=1"
+
+EXTRA_OEMAKE = "X11PREFIX='${STAGING_DIR_TARGET}${layout_prefix}' PKG_CONFIG='${STAGING_BINDIR_NATIVE}/pkg-config'"
+CFLAGS_append = " -I${STAGING_INCDIR}/X11"
+LDFLAGS_append = " -L${STAGING_LIBDIR}/X11"
+
+do_install() {
+ oe_runmake 'BINDIR=${D}${bindir}' install
+}