summaryrefslogtreecommitdiff
path: root/recipes/sdcc/sdcc_2.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sdcc/sdcc_2.8.0.bb')
-rw-r--r--recipes/sdcc/sdcc_2.8.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/sdcc/sdcc_2.8.0.bb b/recipes/sdcc/sdcc_2.8.0.bb
new file mode 100644
index 0000000000..07993eb0a1
--- /dev/null
+++ b/recipes/sdcc/sdcc_2.8.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION= "SDCC - Small Device C Compiler"
+LICENSE = "GPL"
+SECTION = "devel"
+HOMEPAGE = "http://sdcc.sourceforge.net"
+DEPENDS = "sdcc-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sdcc/sdcc-src-${PV}.tar.bz2 \
+ file://use-native-tools.patch;patch=1"
+
+S = "${WORKDIR}/sdcc"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+