summaryrefslogtreecommitdiff
path: root/recipes/mono/mono-native_2.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mono/mono-native_2.6.3.bb')
-rw-r--r--recipes/mono/mono-native_2.6.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/mono/mono-native_2.6.3.bb b/recipes/mono/mono-native_2.6.3.bb
new file mode 100644
index 0000000000..03820d3cd3
--- /dev/null
+++ b/recipes/mono/mono-native_2.6.3.bb
@@ -0,0 +1,22 @@
+require mono.inc
+DEPENDS = "glib-2.0-native perl-native"
+
+PR = "${INC_PR}.0"
+
+SRC_URI += ""
+
+inherit native
+
+do_fix_libtool_name() {
+ # inherit native will make that all native tools that are being
+ # built are prefixed with something like "i686-linux-",
+ # including libtool. Fix up some hardcoded libtool names:
+ for i in "${S}"/runtime/*-wrapper.in; do
+ sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+ done
+}
+addtask fix_libtool_name after do_patch before do_configure
+
+SRC_URI[md5sum] = "b1dc21bac2c7c75814a9f32246eadadd"
+SRC_URI[sha256sum] = "0ecb82d2007f472f8eebc85c349813515bf642e6ea021890ece40555ad50d947"
+