summaryrefslogtreecommitdiff
path: root/recipes/images/corecdp-webserver-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/corecdp-webserver-image.bb')
-rw-r--r--recipes/images/corecdp-webserver-image.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/images/corecdp-webserver-image.bb b/recipes/images/corecdp-webserver-image.bb
new file mode 100644
index 0000000000..8b27023bc3
--- /dev/null
+++ b/recipes/images/corecdp-webserver-image.bb
@@ -0,0 +1,17 @@
+require corecdp-base-image.bb
+
+LIGHTTPD = "lighttpd \
+ lighttpd-module-cgi lighttpd-module-indexfile \
+ lighttpd-module-redirect lighttpd-module-auth \
+ lighttpd-module-access lighttpd-module-accesslog \
+ lighttpd-module-rewrite lighttpd-module-proxy lighttpd-module-fastcgi \
+ lighttpd-module-scgi lighttpd-module-alias \
+ lighttpd-module-dirlisting lighttpd-module-staticfile \
+ "
+
+IMAGE_INSTALL += "${LIGHTTPD}"
+
+IMAGE_INSTALL += "php php-cli php-cgi"
+
+export IMAGE_BASENAME = "corecdp-webserver-image"
+