summaryrefslogtreecommitdiff
path: root/recipes/images/corecdp-full-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/corecdp-full-image.bb')
-rw-r--r--recipes/images/corecdp-full-image.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/images/corecdp-full-image.bb b/recipes/images/corecdp-full-image.bb
new file mode 100644
index 0000000000..036ee3c6dd
--- /dev/null
+++ b/recipes/images/corecdp-full-image.bb
@@ -0,0 +1,37 @@
+require corecdp-base-image.bb
+
+LIGHTTPD = "lighttpd \
+ lighttpd-module-cgi lighttpd-module-indexfile \
+ lighttpd-module-redirect lighttpd-module-auth \
+ lighttpd-module-access lighttpd-module-accesslog \
+ lighttpd-module-rewrite lighttpd-module-proxy lighttpd-module-fastcgi \
+ lighttpd-module-scgi lighttpd-module-alias \
+ lighttpd-module-dirlisting lighttpd-module-staticfile \
+ "
+
+IMAGE_INSTALL += "${LIGHTTPD}"
+
+IMAGE_INSTALL += "sqlite3"
+
+IMAGE_INSTALL += "perl"
+IMAGE_INSTALL += "perl-module-io"
+IMAGE_INSTALL += "libdevice-serialport-perl"
+IMAGE_INSTALL += "libexpect-perl"
+
+IMAGE_INSTALL += "python"
+IMAGE_INSTALL += "python-pyserial"
+IMAGE_INSTALL += "python-simplejson"
+IMAGE_INSTALL += "python-unixadmin"
+IMAGE_INSTALL += "python-textutils"
+IMAGE_INSTALL += "python-html"
+IMAGE_INSTALL += "python-sqlite3"
+
+IMAGE_INSTALL += "ruby"
+
+# Java VM
+IMAGE_INSTALL += "jamvm"
+
+IMAGE_INSTALL += "php php-cli php-cgi"
+
+export IMAGE_BASENAME = "corecdp-full-image"
+