summaryrefslogtreecommitdiff
path: root/recipes/images/corecdp-base-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/corecdp-base-image.bb')
-rw-r--r--recipes/images/corecdp-base-image.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes/images/corecdp-base-image.bb b/recipes/images/corecdp-base-image.bb
new file mode 100644
index 0000000000..bf1538a84f
--- /dev/null
+++ b/recipes/images/corecdp-base-image.bb
@@ -0,0 +1,69 @@
+inherit image
+
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+# remove kernel package from rootfs to save space
+# uImage is flashed to a different partition, so it isn't needed
+PACKAGE_REMOVE = "kernel-image-*"
+ROOTFS_POSTPROCESS_COMMAND += "opkg-cl ${IPKG_ARGS} -force-depends \
+ remove ${PACKAGE_REMOVE};"
+
+CORE_FEATURES = "u-boot sysfsutils module-init-tools kernel-modules \
+ mtd-utils \
+ usbutils usb-gadget-mode \
+ bash \
+ "
+
+FILESYSTEM_FEATURES = "e2fsprogs e2fsprogs-mke2fs e2fsprogs-fsck \
+ dosfstools \
+ cifs \
+ "
+
+NETWORKING_FEATURES = "ppp \
+ iptables iptables-utils \
+ atftp netkit-ftp lftp curl \
+ openssl \
+ "
+
+TIME_FEATURES = "tzdata \
+ cron \
+ ntpdate \
+ "
+
+# mts-io: IO Controller for Multi-Tech hardware.
+# (LEDs, temp sensor, serial lines, and more)
+#
+# config: Handles default config files stored in /var/config.
+# /var/config is mounted on separate flash partition so that config
+# files survive flashing of rootfs. See recipe for details.
+#
+# u-boot-linux-utils: U-Boot environment access from Linux
+MULTITECH_FEATURES = "mts-io \
+ config \
+ u-boot-linux-utils \
+ "
+
+# Tools to flash kernel and rootfs on reboot
+UPGRADE_FEATURES = "upgrade-reboot mtd-utils-static"
+
+MISC_FEATURES = "minicom nano"
+
+# All the packages to be installed
+IMAGE_INSTALL = "task-boot \
+ util-linux-ng-mount util-linux-ng-umount \
+ ${DISTRO_SSH_DAEMON} \
+ ${CORE_FEATURES} \
+ ${FILESYSTEM_FEATURES} \
+ ${NETWORKING_FEATURES} \
+ ${TIME_FEATURES} \
+ ${MULTITECH_FEATURES} \
+ ${UPGRADE_FEATURES} \
+ ${MISC_FEATURES} \
+ "
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+export IMAGE_BASENAME = "corecdp-base-image"
+IMAGE_LINGUAS = ""
+
+require corecdp-tftpboot.inc