summaryrefslogtreecommitdiff
path: root/recipes/ifupdown/ifupdown_0.6.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ifupdown/ifupdown_0.6.8.bb')
-rw-r--r--recipes/ifupdown/ifupdown_0.6.8.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/ifupdown/ifupdown_0.6.8.bb b/recipes/ifupdown/ifupdown_0.6.8.bb
new file mode 100644
index 0000000000..53ccb5fe6c
--- /dev/null
+++ b/recipes/ifupdown/ifupdown_0.6.8.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "High level tools to configure network interfaces \
+This package provides the tools ifup and ifdown which may be used to \
+configure (or, respectively, deconfigure) network interfaces, based on \
+the file /etc/network/interfaces."
+LICENSE = "GPL"
+
+SECTION = "base"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/i/ifupdown/ifupdown_${PV}.tar.gz \
+ file://busybox.patch;patch=1 \
+ file://udhcpc.patch;patch=1 \
+ file://zeroconf.patch;patch=1 \
+ file://init \
+ file://interfaces"
+
+EXTRA_OEMAKE = ""
+
+do_compile () {
+ chmod a+rx *.pl *.sh
+ oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
+}
+
+do_install () {
+ install -d ${D}${sysconfdir}/init.d \
+ ${D}${sysconfdir}/network \
+ ${D}${mandir}/man8 \
+ ${D}${mandir}/man5 \
+ ${D}${base_sbindir}
+ install -m 0755 ifup ${D}${base_sbindir}/
+ ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
+ install -m 0644 ${WORKDIR}/init ${D}${sysconfdir}/init.d/networking
+ install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
+ install -m 0644 ifup.8 ${D}${mandir}/man8
+ install -m 0644 interfaces.5 ${D}${mandir}/man5
+ cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
+}