summaryrefslogtreecommitdiff
path: root/recipes/freesmartphone/fsodeviced_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/fsodeviced_git.bb')
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 2516c89aff..69c948f733 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -6,7 +6,7 @@ RDEPENDS += "libcanberra-alsa"
RRECOMMENDS += "fso-alsa-data"
PV = "0.9.0+gitr${SRCREV}"
PE = "1"
-PR = "${INC_PR}.6"
+PR = "${INC_PR}.7"
EXTRA_OECONF = "\
--enable-kernel26-rfkill \
@@ -18,11 +18,16 @@ inherit update-rc.d
INITSCRIPT_NAME = "fsodeviced"
INITSCRIPT_PARAMS = "defaults 27"
-SRC_URI += "file://fsodeviced"
+SRC_URI += "file://fsodeviced file://fsodeviced.conf"
do_install_append() {
install -d ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/fsodeviced ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/freesmartphone/
+ install -m 0644 ${WORKDIR}/fsodeviced.conf ${D}${sysconfdir}/freesmartphone/
}
-FILES_${PN} += "${sysconfdir}/init.d/fsodeviced"
+FILES_${PN} += "
+ ${sysconfdir}/init.d/fsodeviced \
+ ${sysconfdir}/freesmartphone/fsodeviced.conf \
+"