summaryrefslogtreecommitdiff
path: root/recipes/freesmartphone/fsodeviced_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/fsodeviced_git.bb')
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 1b01241e4c..56773cc6b1 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -5,4 +5,19 @@ DEPENDS += "alsa-lib libcanberra libfsoresource"
RDEPENDS += "libcanberra-alsa"
RRECOMMENDS += "fso-alsa-data"
PV = "0.9.0+gitr${SRCREV}"
-PR = "${INC_PR}.0"
+PE = "1"
+PR = "${INC_PR}.2"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "fsodeviced"
+INITSCRIPT_PARAMS = "defaults 27"
+
+SRC_URI += "file://fsodeviced"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fsodeviced ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${sysconfdir}/init.d/fsodeviced"