summaryrefslogtreecommitdiff
path: root/packages/udev/udev-063
diff options
context:
space:
mode:
Diffstat (limited to 'packages/udev/udev-063')
-rw-r--r--packages/udev/udev-063/.mtn2git_empty0
-rw-r--r--packages/udev/udev-063/flags.patch53
-rw-r--r--packages/udev/udev-063/noasmlinkage.patch38
3 files changed, 91 insertions, 0 deletions
diff --git a/packages/udev/udev-063/.mtn2git_empty b/packages/udev/udev-063/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/udev/udev-063/.mtn2git_empty
diff --git a/packages/udev/udev-063/flags.patch b/packages/udev/udev-063/flags.patch
new file mode 100644
index 0000000000..e6969f2f63
--- /dev/null
+++ b/packages/udev/udev-063/flags.patch
@@ -0,0 +1,53 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udev-062/Makefile~flags.patch
++++ udev-062/Makefile
+@@ -151,16 +151,17 @@
+
+ SYSFS = $(PWD)/libsysfs/sysfs.a
+
+-CFLAGS += -I$(PWD)/libsysfs/sysfs \
++override CFLAGS += -I$(PWD)/libsysfs/sysfs \
+ -I$(PWD)/libsysfs
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip or optimize
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -O1 -g -DDEBUG
++ CFLAGS += -O1 -g
++ override CFLAGS += -DDEBUG
+ LDFLAGS += -Wl
+ STRIPCMD = /bin/true -Since_we_are_debugging
+ else
+@@ -176,19 +177,20 @@
+ KLCC = $(KLIBC_INSTALL)/bin/$(CROSS)klcc
+ CC = $(KLCC)
+ LD = $(KLCC)
++ override LDFLAGS += -static
+ else
+- CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
++ override CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+ endif
+
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
+- LDFLAGS += -static
++ override CFLAGS += -DUSE_STATIC
++ override LDFLAGS += -static
+ endif
+
+ ifeq ($(strip $(V)),false)
diff --git a/packages/udev/udev-063/noasmlinkage.patch b/packages/udev/udev-063/noasmlinkage.patch
new file mode 100644
index 0000000000..0d8e854c0e
--- /dev/null
+++ b/packages/udev/udev-063/noasmlinkage.patch
@@ -0,0 +1,38 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udev-062/udev.c~noasmlinkage.patch
++++ udev-062/udev.c
+@@ -54,7 +54,7 @@
+ }
+ #endif
+
+-static void asmlinkage sig_handler(int signum)
++static void sig_handler(int signum)
+ {
+ switch (signum) {
+ case SIGALRM:
+--- udev-062/udevd.c~noasmlinkage.patch
++++ udev-062/udevd.c
+@@ -639,7 +639,7 @@
+ return msg;
+ }
+
+-static void asmlinkage sig_handler(int signum)
++static void sig_handler(int signum)
+ {
+ int rc;
+
+--- udev-062/udevstart.c~noasmlinkage.patch
++++ udev-062/udevstart.c
+@@ -323,7 +323,7 @@
+ exec_list(&device_list);
+ }
+
+-static void asmlinkage sig_handler(int signum)
++static void sig_handler(int signum)
+ {
+ switch (signum) {
+ case SIGALRM: