summaryrefslogtreecommitdiff
path: root/packages/uboot
diff options
context:
space:
mode:
Diffstat (limited to 'packages/uboot')
-rw-r--r--packages/uboot/u-boot-1.1.6/.mtn2git_empty0
-rw-r--r--packages/uboot/u-boot-1.1.6/devkit-idp.patch28
-rw-r--r--packages/uboot/u-boot_1.1.6.bb5
-rw-r--r--packages/uboot/uboot-devkitidp-pxa255_cvs.bb37
4 files changed, 31 insertions, 39 deletions
diff --git a/packages/uboot/u-boot-1.1.6/.mtn2git_empty b/packages/uboot/u-boot-1.1.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/uboot/u-boot-1.1.6/.mtn2git_empty
diff --git a/packages/uboot/u-boot-1.1.6/devkit-idp.patch b/packages/uboot/u-boot-1.1.6/devkit-idp.patch
new file mode 100644
index 0000000000..1460c3d1f0
--- /dev/null
+++ b/packages/uboot/u-boot-1.1.6/devkit-idp.patch
@@ -0,0 +1,28 @@
+Index: u-boot-1.1.6/board/pxa255_idp/memsetup.S
+===================================================================
+--- u-boot-1.1.6.orig/board/pxa255_idp/memsetup.S
++++ u-boot-1.1.6/board/pxa255_idp/memsetup.S
+@@ -41,8 +41,8 @@ DRAM_SIZE: .long CFG_DRAM_SIZE
+ /*
+ * Memory setup
+ */
+-.globl memsetup
+-memsetup:
++.globl lowlevel_init
++lowlevel_init:
+
+ mov r10, lr
+
+Index: u-boot-1.1.6/include/configs/pxa255_idp.h
+===================================================================
+--- u-boot-1.1.6.orig/include/configs/pxa255_idp.h
++++ u-boot-1.1.6/include/configs/pxa255_idp.h
+@@ -41,7 +41,7 @@
+ * If we are developing, we might want to start armboot from ram
+ * so we MUST NOT initialize critical regs like mem-timing ...
+ */
+-#define CONFIG_INIT_CRITICAL /* undef for developing */
++#undef CONFIG_INIT_CRITICAL /* undef for developing */
+
+ /*
+ * define the following to enable debug blinks. A debug blink function
diff --git a/packages/uboot/u-boot_1.1.6.bb b/packages/uboot/u-boot_1.1.6.bb
index b45e86611b..bfd0fb8132 100644
--- a/packages/uboot/u-boot_1.1.6.bb
+++ b/packages/uboot/u-boot_1.1.6.bb
@@ -4,9 +4,10 @@ SECTION = "bootloader"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
-SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-1.1.6.tar.bz2"
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-1.1.6.tar.bz2 \
+ file://devkit-idp.patch;patch=1"
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
diff --git a/packages/uboot/uboot-devkitidp-pxa255_cvs.bb b/packages/uboot/uboot-devkitidp-pxa255_cvs.bb
deleted file mode 100644
index 4e50706087..0000000000
--- a/packages/uboot/uboot-devkitidp-pxa255_cvs.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-BROKEN = "1"
-#not fetchable patch used
-
-DESCRIPTION = "U-boot bootloader"
-SECTION = "bootloader"
-PRIORITY = "optional"
-LICENSE = "GPL"
-SRCDATE = "20050818"
-PV = "0.0+cvs${SRCDATE}"
-PR = "r3"
-
-PROVIDES = "virtual/bootloader"
-
-S = "${WORKDIR}/u-boot"
-
-SRC_URI = "cvs://anonymous@u-boot.cvs.sourceforge.net/cvsroot/u-boot;module=u-boot \
- file://arm_flags.patch;patch=1 \
- ftp://ftp.accelent.com/pxa255_idp/uboot/u-boot-1.1.2-cvs20050818-r2-pxa255idp1.patch;patch=1"
-
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-TARGET_LDFLAGS = ""
-UBOOT_MACHINE = "pxa255_idp_config"
-
-inherit base
-
-do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake all
-}
-
-do_deploy () {
- install -d ${DEPLOY_DIR_IMAGE}
- install ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/u-boot-${MACHINE}-${DATETIME}.bin
-}
-do_deploy[dirs] = "${S}"
-addtask deploy before do_build after do_compile
-