summaryrefslogtreecommitdiff
path: root/packages/subversion/subversion_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/subversion/subversion_1.3.1.bb')
-rw-r--r--packages/subversion/subversion_1.3.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/subversion/subversion_1.3.1.bb b/packages/subversion/subversion_1.3.1.bb
new file mode 100644
index 0000000000..ac537cf310
--- /dev/null
+++ b/packages/subversion/subversion_1.3.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util-0.9.12 neon"
+MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
+LICENSE = "Apache/BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+PR = "r1"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://apr-regex.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${BUILD_SYS} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR} \
+ --with-apr-util=${STAGING_BINDIR}"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}