summaryrefslogtreecommitdiff
path: root/packages/sidplayer/sidplayer_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/sidplayer/sidplayer_1.5.0.bb')
-rw-r--r--packages/sidplayer/sidplayer_1.5.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/sidplayer/sidplayer_1.5.0.bb b/packages/sidplayer/sidplayer_1.5.0.bb
index e69de29bb2..1916176694 100644
--- a/packages/sidplayer/sidplayer_1.5.0.bb
+++ b/packages/sidplayer/sidplayer_1.5.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A SID Player for the Qt/Embedded based Palmtop Environments"
+SECTION = "opie/multimedia"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+HOMEPAGE = "http://sidplayer.sourceforge.net/"
+DEPENDS = "libsidplay"
+PR = "r1"
+
+SRC_URI = "http://sidplayer.sourceforge.net/sidplayer.tar.gz \
+ file://use-external-libsidplay.patch;patch=1 \
+ file://gcc3.patch;patch=1 \
+ file://gcc34.patch;patch=1"
+S = "${WORKDIR}/sidplayer"
+
+EXTRA_QMAKEVARS_PRE = "QMAKE_INCDIR=${STAGING_INCDIR}/sidplay"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics
+ cp -a ../apps ../bin ../pics ${D}${palmtopdir}/
+}