summaryrefslogtreecommitdiff
path: root/packages/ruby
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ruby')
-rw-r--r--packages/ruby/ruby-native_1.8.4.bb3
-rw-r--r--packages/ruby/ruby_1.8.3.bb11
-rw-r--r--packages/ruby/ruby_1.8.4.bb11
-rw-r--r--packages/ruby/ruby_1.8.5.bb18
4 files changed, 16 insertions, 27 deletions
diff --git a/packages/ruby/ruby-native_1.8.4.bb b/packages/ruby/ruby-native_1.8.4.bb
deleted file mode 100644
index c73e905ef4..0000000000
--- a/packages/ruby/ruby-native_1.8.4.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require ruby_${PV}.bb
-inherit native
-DEPENDS = ""
diff --git a/packages/ruby/ruby_1.8.3.bb b/packages/ruby/ruby_1.8.3.bb
deleted file mode 100644
index 981f826dc6..0000000000
--- a/packages/ruby/ruby_1.8.3.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-DESCRIPTION = "Ruby is an interpreted scripting language \
-for quick and easy object-oriented programming."
-SECTION = "devel/ruby"
-DEPENDS = "ruby-native"
-PRIORITY = "optional"
-LICENSE = "GPL"
-
-SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz"
-S = "${WORKDIR}/ruby-${PV}"
-
-inherit autotools
diff --git a/packages/ruby/ruby_1.8.4.bb b/packages/ruby/ruby_1.8.4.bb
deleted file mode 100644
index 981f826dc6..0000000000
--- a/packages/ruby/ruby_1.8.4.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-DESCRIPTION = "Ruby is an interpreted scripting language \
-for quick and easy object-oriented programming."
-SECTION = "devel/ruby"
-DEPENDS = "ruby-native"
-PRIORITY = "optional"
-LICENSE = "GPL"
-
-SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz"
-S = "${WORKDIR}/ruby-${PV}"
-
-inherit autotools
diff --git a/packages/ruby/ruby_1.8.5.bb b/packages/ruby/ruby_1.8.5.bb
index 981f826dc6..972d56e14c 100644
--- a/packages/ruby/ruby_1.8.5.bb
+++ b/packages/ruby/ruby_1.8.5.bb
@@ -1,11 +1,25 @@
DESCRIPTION = "Ruby is an interpreted scripting language \
for quick and easy object-oriented programming."
SECTION = "devel/ruby"
-DEPENDS = "ruby-native"
+DEPENDS = "ruby-native zlib openssl"
PRIORITY = "optional"
LICENSE = "GPL"
-SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz"
+SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz \
+ file://extmk_run.patch;patch=1 \
+ file://disable_wide_getaddrinfo_check.patch;patch=1"
+
S = "${WORKDIR}/ruby-${PV}"
inherit autotools
+
+# This snippet lets compiled extensions which rely on external libraries,
+# such as zlib, compile properly. If we don't do this, then when extmk.rb
+# runs, it uses the native libraries instead of the target libraries, and so
+# none of the linking operations succeed -- which makes extconf.rb think
+# that the libraries aren't available and hence that the extension can't be
+# built.
+
+do_configure_prepend() {
+ sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
+}