summaryrefslogtreecommitdiff
path: root/packages/qt4/qtopia-core_4.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/qt4/qtopia-core_4.3.3.bb')
-rw-r--r--packages/qt4/qtopia-core_4.3.3.bb42
1 files changed, 0 insertions, 42 deletions
diff --git a/packages/qt4/qtopia-core_4.3.3.bb b/packages/qt4/qtopia-core_4.3.3.bb
index e7187b9309..65f0203ea0 100644
--- a/packages/qt4/qtopia-core_4.3.3.bb
+++ b/packages/qt4/qtopia-core_4.3.3.bb
@@ -1,43 +1 @@
-QT_CONFIG_FLAGS += " \
- -nomake demos -nomake examples -nomake tools \
- -qt-mouse-tslib -qt-gfx-transformed -embedded ${QT_ARCH}"
-
-do_stage_append() {
- echo "Fixing up Qt"
- cd ${STAGING_LIBDIR}/pkgconfig
- sed -i s#"-L${S}/lib"##g Qt*.pc
- sed -i s#"moc_location=${S}/bin/moc"#moc_location=${STAGING_BINDIR}/moc4# Qt*.pc
- sed -i s#"uic_location=${S}/bin/uic"#uic_location=${STAGING_BINDIR}/uic4# Qt*.pc
-}
-
-do_install() {
- oe_runmake install INSTALL_ROOT=${D}
-
- # These are host binaries, we should only use them in staging
- rm -rf ${D}/${bindir}
- rm -rf ${D}/${datadir}/mkspecs
-
- touch ${D}/${libdir}/fonts/fontdir
-}
-
-
-
-STAGE_TEMP = "${WORKDIR}/temp-staging"
-do_stage() {
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake install INSTALL_ROOT=${STAGE_TEMP}
-
- install -d ${STAGING_INCDIR}/qtopiacore4
- install -d ${STAGING_LIBDIR}/qtopiacore4
- cp -pPRf ${STAGE_TEMP}/$includedir/* ${STAGING_INCDIR}/qtopiacore4/
-
- for i in ${STAGE_TEMP}/${libdir}/*.la
- do
- oe_libinstall -C ${STAGE_TEMP}/${libdir} -so $(basename $i .la) ${STAGING_LIBDIR}/qtopiacore4
- done
-
- rm -rf ${STAGE_TEMP}
-}
-
require qtopia-core.inc