summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-dweba_0.9.9+1.0.0pre14.bb14
-rw-r--r--packages/python/python-pygtk-1.2_0.6.12.bb8
-rw-r--r--packages/python/python-pylinda_0.6.bb2
-rw-r--r--packages/python/python-spyro_0.9.22.bb13
4 files changed, 18 insertions, 19 deletions
diff --git a/packages/python/python-dweba_0.9.9+1.0.0pre14.bb b/packages/python/python-dweba_0.9.9+1.0.0pre14.bb
new file mode 100644
index 0000000000..ddc5979eab
--- /dev/null
+++ b/packages/python/python-dweba_0.9.9+1.0.0pre14.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Dweba is a framework to develop distributed and web applications \
+for the python programming language."
+HOMEPAGE = "http://www.threekong.com"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "ml0"
+
+RPV = "1.0.0-pre14"
+
+SRC_URI = "http://www.threekong.com/download/dweba/dweba-${RPV}.tar.gz"
+S = "${WORKDIR}/dweba-${RPV}"
+
+inherit distutils
diff --git a/packages/python/python-pygtk-1.2_0.6.12.bb b/packages/python/python-pygtk-1.2_0.6.12.bb
index 502c4cde39..0b153ce1e5 100644
--- a/packages/python/python-pygtk-1.2_0.6.12.bb
+++ b/packages/python/python-pygtk-1.2_0.6.12.bb
@@ -5,14 +5,14 @@ LICENSE = "LGPL"
DEPENDS = "gtk+-1.2"
RDEPENDS = "python-shell python-re"
SRCNAME = "pygtk"
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/python/v1.2/${SRCNAME}-${PV}.tar.gz \
file://remove-imlib-et-al.patch;patch=1 \
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit autotools pkgconfig distutils-base
+inherit autotools_stage pkgconfig distutils-base
EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
@@ -22,6 +22,4 @@ do_configure_prepend() {
rm -f aclocal.m4
}
-do_stage() {
- autotools_stage_includes
-}
+FILES_${PN}-dev += "${datadir}/pygtk"
diff --git a/packages/python/python-pylinda_0.6.bb b/packages/python/python-pylinda_0.6.bb
index 3c7124f2ac..a43dd7e7f8 100644
--- a/packages/python/python-pylinda_0.6.bb
+++ b/packages/python/python-pylinda_0.6.bb
@@ -6,7 +6,7 @@ LICENSE = "LGPL"
SRCNAME = "linda"
PR = "r1"
-SRC_URI = "http://www-users.cs.york.ac.uk/~aw/pylinda/dist/linda-${PV}.tar.gz \
+SRC_URI = "http://www.handhelds.org/~aquadran/distro/latest/sources/linda-${PV}.tar.gz \
file://honor-datadir.patch;patch=1"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/packages/python/python-spyro_0.9.22.bb b/packages/python/python-spyro_0.9.22.bb
deleted file mode 100644
index 9cafd883a4..0000000000
--- a/packages/python/python-spyro_0.9.22.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "Simplified Python Remote Objects is a multilingual object request broker. \
-SPyRO uses the most efficient (or available) connection between peers to minimize costs \
-of transport and parsing in the communication."
-HOMEPAGE = "http://www.spyron.org/"
-SECTION = "devel/python"
-PRIORITY = "optional"
-LICENSE = "MIT"
-PR = "ml1"
-
-SRC_URI = "http://lsc.fie.umich.mx/%7esadit/spyro/download/SPyRO-${PV}.tar.gz"
-S="${WORKDIR}/SPyRO-${PV}"
-
-inherit distutils