summaryrefslogtreecommitdiff
path: root/packages/python/python-simplejson_1.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python/python-simplejson_1.7.1.bb')
-rw-r--r--packages/python/python-simplejson_1.7.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/python/python-simplejson_1.7.1.bb b/packages/python/python-simplejson_1.7.1.bb
new file mode 100644
index 0000000000..e41d9085af
--- /dev/null
+++ b/packages/python/python-simplejson_1.7.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT"
+DEPENDS = "python-setuptools"
+# python-netserver is needed for cgi stuff
+# python-zlib is needed to unpack egg created by setuptools
+RDEPENDS = "python-core python-re python-io python-netserver python-zlib"
+SRCNAME = "simplejson"
+PR = "r0"
+
+SRC_URI = "http://cheeseshop.python.org/packages/source/s/simplejson/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+# Deal with .pth file error
+export PYTHONPATH="${D}/${libdir}/python2.4/site-packages"
+