summaryrefslogtreecommitdiff
path: root/packages/python/python-pygame-1.7.1/Setup
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python/python-pygame-1.7.1/Setup')
-rw-r--r--packages/python/python-pygame-1.7.1/Setup57
1 files changed, 0 insertions, 57 deletions
diff --git a/packages/python/python-pygame-1.7.1/Setup b/packages/python/python-pygame-1.7.1/Setup
deleted file mode 100644
index c4558b39bb..0000000000
--- a/packages/python/python-pygame-1.7.1/Setup
+++ /dev/null
@@ -1,57 +0,0 @@
-#This Setup file is used by the setup.py script to configure the
-#python extensions. You will likely use the "config.py" which will
-#build a correct Setup file for you based on your system settings.
-#If not, the format is simple enough to edit by hand. First change
-#the needed commandline flags for each dependency, then comment out
-#any unavailable optional modules in the first optional section.
-
-#SDL = ???
-
-FONT = -lSDL_ttf-2.0
-IMAGE = -lSDL_image-1.2
-MIXER = -lSDL_mixer-1.2
-SMPEG = -lsmpeg $(SDL)
-NUMERIC = -I.
-
-
-
-#the following modules are optional. you will want to compile
-#everything you can, but you can ignore ones you don't have
-#dependencies for, just comment them out
-
-imageext src/imageext.c $(SDL) $(IMAGE)
-font src/font.c $(SDL) $(FONT)
-mixer src/mixer.c $(SDL) $(MIXER)
-mixer_music src/music.c $(SDL) $(MIXER)
-movie src/movie.c $(SDL) $(SMPEG)
-surfarray src/surfarray.c $(SDL) $(NUMERIC)
-sndarray src/sndarray.c $(SDL) $(NUMERIC) $(MIXER)
-
-
-
-#these modules are required for pygame to run. they only require
-#SDL as a dependency. these should not be altered
-
-base src/base.c $(SDL)
-cdrom src/cdrom.c $(SDL)
-constants src/constants.c $(SDL)
-display src/display.c $(SDL)
-event src/event.c $(SDL)
-key src/key.c $(SDL)
-mouse src/mouse.c $(SDL)
-rect src/rect.c $(SDL)
-rwobject src/rwobject.c $(SDL)
-surface src/surface.c src/alphablit.c $(SDL)
-surflock src/surflock.c $(SDL)
-time src/time.c $(SDL)
-joystick src/joystick.c $(SDL)
-draw src/draw.c $(SDL)
-image src/image.c $(SDL)
-transform src/transform.c src/rotozoom.c src/scale2x.c $(SDL)
-
-
-#the following are placeholders. setup.py can use them to help
-#auto-copy needed DLLs into the pygame installation folder.
-#you can simply ignore these lines under non-windows, no need to
-#comment out.
-COPYLIB_smpeg $(SDL) $(SMPEG)