summaryrefslogtreecommitdiff
path: root/packages/postfix/postfix_2.0.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/postfix/postfix_2.0.20.bb')
-rw-r--r--packages/postfix/postfix_2.0.20.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/packages/postfix/postfix_2.0.20.bb b/packages/postfix/postfix_2.0.20.bb
index 483e95f19c..c826dc5469 100644
--- a/packages/postfix/postfix_2.0.20.bb
+++ b/packages/postfix/postfix_2.0.20.bb
@@ -21,3 +21,12 @@ do_compile () {
do_install () {
sh ./postfix-install 'install_root=${D}' -non-interactive
}
+
+pkg_postinst () {
+ grep postfix /etc/passwd || adduser --disabled-password --home=/var/spool/mail --ingroup nogroup postfix
+}
+
+pkg_postrm () {
+ grep postfix /etc/passwd && deluser postfix
+}
+