summaryrefslogtreecommitdiff
path: root/packages/portmap/portmap-5-25/make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/portmap/portmap-5-25/make.patch')
-rw-r--r--packages/portmap/portmap-5-25/make.patch73
1 files changed, 0 insertions, 73 deletions
diff --git a/packages/portmap/portmap-5-25/make.patch b/packages/portmap/portmap-5-25/make.patch
deleted file mode 100644
index 7726846b7c..0000000000
--- a/packages/portmap/portmap-5-25/make.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: portmap_5beta/Makefile
-===================================================================
---- portmap_5beta.orig/Makefile 2006-12-19 10:32:58.000000000 +0000
-+++ portmap_5beta/Makefile 2006-12-19 10:35:54.000000000 +0000
-@@ -110,6 +110,13 @@
- #
- #CONST = -Dconst=
-
-+DESTDIR =
-+prefix = /usr
-+sbindir = /sbin
-+datadir = $(prefix)/share
-+mandir = $(datadir)/man
-+docdir = $(datadir)/doc/portmap
-+
- ### End of configurable stuff.
- ##############################
-
-@@ -127,7 +134,7 @@
- COPT = $(CONST) $(HOSTS_ACCESS) $(CHECK_PORT) \
- $(SYS) -DFACILITY=$(FACILITY) $(ULONG) $(ZOMBIES) $(BROKEN_PIPE) \
- $(SA_LEN) $(LOOPBACK) $(SETPGRP)
--CFLAGS = -Wall $(COPT) -O2 $(NSARCHS)
-+CFLAGS = -Wall -O2 $(NSARCHS)
- OBJECTS = portmap.o pmap_check.o from_local.o $(AUX)
-
- all: portmap pmap_dump pmap_set
-@@ -142,20 +149,23 @@
- $(CC) $(CFLAGS) -o $@ $? $(LIBS)
-
- from_local: from_local.c
-- cc $(CFLAGS) -DTEST -o $@ from_local.c
-+ $(CC) $(COPT) -DTEST $(CFLAGS) $(LDFLAGS) -o $@ from_local.c
-
- get_myaddress: get_myaddress.c
-- cc $(CFLAGS) -DTEST -o $@ get_myaddress.c $(LIBS)
-+ $(CC) $(COPT) -DTEST $(CFLAGS) $(LDFLAGS) -o $@ get_myaddress.c $(LIBS)
-
- install: all
-- install -o root -g root -m 0755 -s portmap ${BASEDIR}/sbin
-- install -o root -g root -m 0755 -s pmap_dump ${BASEDIR}/sbin
-- install -o root -g root -m 0755 -s pmap_set ${BASEDIR}/sbin
-- install -o root -g root -m 0644 portmap.8 ${BASEDIR}/usr/share/man/man8
-- install -o root -g root -m 0644 pmap_dump.8 ${BASEDIR}/usr/share/man/man8
-- install -o root -g root -m 0644 pmap_set.8 ${BASEDIR}/usr/share/man/man8
-- cat BLURB >${BASEDIR}/usr/share/doc/portmap/portmapper.txt
-- gzip -9f ${BASEDIR}/usr/share/doc/portmap/portmapper.txt
-+ install -d $(DESTDIR)/$(sbindir) \
-+ $(DESTDIR)/$(docdir) \
-+ $(DESTDIR)/$(mandir)/man8
-+ install -m 0755 portmap ${DESTDIR}/sbin
-+ install -m 0755 pmap_dump ${DESTDIR}/sbin
-+ install -m 0755 pmap_set ${DESTDIR}/sbin
-+ install -m 0644 portmap.8 ${DESTDIR}/usr/share/man/man8
-+ install -m 0644 pmap_dump.8 ${DESTDIR}/usr/share/man/man8
-+ install -m 0644 pmap_set.8 ${DESTDIR}/usr/share/man/man8
-+ cat BLURB >${DESTDIR}/usr/share/doc/portmap/portmapper.txt
-+ gzip -9f ${DESTDIR}/usr/share/doc/portmap/portmapper.txt
-
-
- lint:
-@@ -181,3 +191,6 @@
- portmap.o: portmap.c
- portmap.o: pmap_check.h Makefile
- strerror.o: strerror.c
-+
-+%.o: %.c
-+ $(CC) $(COPT) $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -c $*.c -o $*.o