summaryrefslogtreecommitdiff
path: root/packages/perl
diff options
context:
space:
mode:
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl-5.8.4/.mtn2git_empty0
-rw-r--r--packages/perl/perl-5.8.4/Makefile.SH.patch (renamed from packages/perl/files/Makefile.SH.patch)0
-rw-r--r--packages/perl/perl-5.8.4/Makefile.patch (renamed from packages/perl/files/Makefile.patch)0
-rw-r--r--packages/perl/perl-5.8.4/config.sh-arm-linux.patch (renamed from packages/perl/files/config.sh-arm-linux.patch)0
-rw-r--r--packages/perl/perl-5.8.4/config.sh-i686-linux (renamed from packages/perl/files/config.sh-i686-linux)0
-rw-r--r--packages/perl/perl-5.8.4/config.sh-mipsel-linux (renamed from packages/perl/files/config.sh-mipsel-linux)0
-rw-r--r--packages/perl/perl-5.8.4/uclibc.patch (renamed from packages/perl/files/uclibc.patch)0
-rw-r--r--packages/perl/perl.inc27
-rw-r--r--packages/perl/perl_5.8.4.bb26
-rw-r--r--packages/perl/perl_5.8.7.bb16
10 files changed, 35 insertions, 34 deletions
diff --git a/packages/perl/perl-5.8.4/.mtn2git_empty b/packages/perl/perl-5.8.4/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/perl/perl-5.8.4/.mtn2git_empty
diff --git a/packages/perl/files/Makefile.SH.patch b/packages/perl/perl-5.8.4/Makefile.SH.patch
index 35a4e6dfde..35a4e6dfde 100644
--- a/packages/perl/files/Makefile.SH.patch
+++ b/packages/perl/perl-5.8.4/Makefile.SH.patch
diff --git a/packages/perl/files/Makefile.patch b/packages/perl/perl-5.8.4/Makefile.patch
index eec127643b..eec127643b 100644
--- a/packages/perl/files/Makefile.patch
+++ b/packages/perl/perl-5.8.4/Makefile.patch
diff --git a/packages/perl/files/config.sh-arm-linux.patch b/packages/perl/perl-5.8.4/config.sh-arm-linux.patch
index 44d8b1a89d..44d8b1a89d 100644
--- a/packages/perl/files/config.sh-arm-linux.patch
+++ b/packages/perl/perl-5.8.4/config.sh-arm-linux.patch
diff --git a/packages/perl/files/config.sh-i686-linux b/packages/perl/perl-5.8.4/config.sh-i686-linux
index 0978100abc..0978100abc 100644
--- a/packages/perl/files/config.sh-i686-linux
+++ b/packages/perl/perl-5.8.4/config.sh-i686-linux
diff --git a/packages/perl/files/config.sh-mipsel-linux b/packages/perl/perl-5.8.4/config.sh-mipsel-linux
index eedf443f04..eedf443f04 100644
--- a/packages/perl/files/config.sh-mipsel-linux
+++ b/packages/perl/perl-5.8.4/config.sh-mipsel-linux
diff --git a/packages/perl/files/uclibc.patch b/packages/perl/perl-5.8.4/uclibc.patch
index ce8fe80ff2..ce8fe80ff2 100644
--- a/packages/perl/files/uclibc.patch
+++ b/packages/perl/perl-5.8.4/uclibc.patch
diff --git a/packages/perl/perl.inc b/packages/perl/perl.inc
index 64e548a121..cda260efcd 100644
--- a/packages/perl/perl.inc
+++ b/packages/perl/perl.inc
@@ -9,35 +9,10 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://Makefile.patch;patch=1 \
file://config.sh-arm-linux.patch;patch=1 \
file://libperl-5.8.3-create-libperl-soname.patch;patch=1;pnum=0 \
- file://uclibc.patch;patch=1 \
- file://Makefile.SH.patch \
- file://config.sh-mipsel-linux \
- file://config.sh-i686-linux"
+ file://Makefile.SH.patch"
HOSTPERL="${STAGING_BINDIR_NATIVE}/perl${PV}"
-do_configure() {
- ln -sf ${HOSTPERL} ${STAGING_BINDIR_NATIVE}/hostperl
- cp ${HOSTPERL} hostperl
- cd Cross
- rm -f Makefile.SH.patch
- cp ${WORKDIR}/Makefile.SH.patch .
- cp ${WORKDIR}/config.sh-mipsel-linux .
- cp ${WORKDIR}/config.sh-i686-linux .
- cat config.sh-arm-linux | sed -e "s,arm-linux,armeb-linux,g" > config.sh-armeb-linux
- for i in config.sh-*-linux; do
- a="`echo $i|sed -e 's,^config.sh-,,; s,-linux$,,'`"
- newfile="`echo $i|sed -e 's,-linux$,-linux-uclibc,g'`"
- cat $i | sed -e "s,${a}-linux,${a}-linux-uclibc,g; \
- s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
- done
- sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
- rm -f config
- echo "ARCH = ${TARGET_ARCH}" > config
- echo "OS = ${TARGET_OS}" >> config
- oe_runmake patch
-}
-
do_compile() {
sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
cd Cross
diff --git a/packages/perl/perl_5.8.4.bb b/packages/perl/perl_5.8.4.bb
index 7509f1b66b..10a871c8dd 100644
--- a/packages/perl/perl_5.8.4.bb
+++ b/packages/perl/perl_5.8.4.bb
@@ -1,3 +1,29 @@
require perl.inc
PR = "r5"
+
+SRC_URI += "file://uclibc.patch;patch=1 \
+ file://config.sh-mipsel-linux \
+ file://config.sh-i686-linux"
+
+do_configure() {
+ ln -sf ${HOSTPERL} ${STAGING_BINDIR_NATIVE}/hostperl
+ cp ${HOSTPERL} hostperl
+ cd Cross
+ rm -f Makefile.SH.patch
+ cp ${WORKDIR}/Makefile.SH.patch .
+ cp ${WORKDIR}/config.sh-mipsel-linux .
+ cp ${WORKDIR}/config.sh-i686-linux .
+ cat config.sh-arm-linux | sed -e "s,arm-linux,armeb-linux,g" > config.sh-armeb-linux
+ for i in config.sh-*-linux; do
+ a="`echo $i|sed -e 's,^config.sh-,,; s,-linux$,,'`"
+ newfile="`echo $i|sed -e 's,-linux$,-linux-uclibc,g'`"
+ cat $i | sed -e "s,${a}-linux,${a}-linux-uclibc,g; \
+ s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
+ done
+ sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
+ rm -f config
+ echo "ARCH = ${TARGET_ARCH}" > config
+ echo "OS = ${TARGET_OS}" >> config
+ oe_runmake patch
+}
diff --git a/packages/perl/perl_5.8.7.bb b/packages/perl/perl_5.8.7.bb
index 12aec88a02..874c95a79c 100644
--- a/packages/perl/perl_5.8.7.bb
+++ b/packages/perl/perl_5.8.7.bb
@@ -7,6 +7,7 @@ require perl.inc
SRC_URI += "file://config.sh-armeb-linux \
file://config.sh-arm-linux \
file://config.sh-powerpc-linux \
+ file://config.sh-mipsel-linux \
file://config.sh-i386-linux \
file://config.sh-i486-linux \
file://config.sh-i586-linux \
@@ -15,14 +16,13 @@ SRC_URI += "file://config.sh-armeb-linux \
file://config.sh-sh3-linux \
file://config.sh-sh4-linux"
-# Patches for sh3/sh4, use gcc to link and override generaet.sh to
-# use PIC mode for compiling shared library objects.
-SRC_URI_append_sh4 += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_sh4 += "file://makefile-usegcc-to-link.patch;patch=1"
-SRC_URI_append_sh3 += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_sh3 += "file://makefile-usegcc-to-link.patch;patch=1"
-SRC_URI_append_powerpc += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_powerpc += "file://makefile-usegcc-to-link.patch;patch=1"
+# Use gcc to link and use PIC mode for compiling shared libs
+GCCLINK_SRC = "file://override-generate-sh.patch;patch=1 \
+ file://makefile-usegcc-to-link.patch;patch=1"
+
+SRC_URI_append_sh4 += " ${GCCLINK_SRC}"
+SRC_URI_append_sh3 += " ${GCCLINK_SRC}"
+SRC_URI_append_powerpc += " ${GCCLINK_SRC}"
PARALLEL_MAKE = ""