summaryrefslogtreecommitdiff
path: root/packages/openmoko-tools/openmoko-set-root-password.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/openmoko-tools/openmoko-set-root-password.bb')
-rw-r--r--packages/openmoko-tools/openmoko-set-root-password.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/openmoko-tools/openmoko-set-root-password.bb b/packages/openmoko-tools/openmoko-set-root-password.bb
new file mode 100644
index 0000000000..a521a1fd6d
--- /dev/null
+++ b/packages/openmoko-tools/openmoko-set-root-password.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Set the root password."
+SUMMARY = "On installation you will be prompted to set a root password. With \
+this password you can then log into the machine."
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+PKG_TAGS_${PN} = "group::programming"
+
+SRC_URI = "svn://svn.openmoko.org/developers/zecke/;module=root-password;proto=http"
+S = "${WORKDIR}/root-password"
+PV = "1.0+svn${SRCREV}"
+
+do_compile () {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 0755 ${S}/root-password ${D}/${sbindir}/${PN}
+}
+
+pkg_postinst_${PN} () {
+ # assume we use display 0
+ DISPLAY=:0 ${sbindir}/${PN}
+}