summaryrefslogtreecommitdiff
path: root/packages/nylon/nylon-statistics.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nylon/nylon-statistics.bb')
-rw-r--r--packages/nylon/nylon-statistics.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/packages/nylon/nylon-statistics.bb b/packages/nylon/nylon-statistics.bb
index aef674b6b2..060e6182d0 100644
--- a/packages/nylon/nylon-statistics.bb
+++ b/packages/nylon/nylon-statistics.bb
@@ -18,13 +18,16 @@ do_install() {
}
pkg_postinst() {
-if test "x$D" == "x"; then
- mkdir -p /etc/cron/crontabs
+if test "x$D" != "x"; then
+ exit 1
+else
if ! grep -q collect.sh /etc/cron/crontabs/root; then
echo "adding crontab"
+ test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
echo "*/5 * * * * /usr/sbin/collect.sh" >> /etc/cron/crontabs/root
fi
update-rc.d -s busybox-cron defaults
+ /etc/init.d/busybox-cron reload
if [ ! -e /etc/httpd.conf ]; then
echo "A:*" > /etc/httpd.conf
fi