summaryrefslogtreecommitdiff
path: root/packages/notecase/notecase_1.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/notecase/notecase_1.2.6.bb')
-rw-r--r--packages/notecase/notecase_1.2.6.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/notecase/notecase_1.2.6.bb b/packages/notecase/notecase_1.2.6.bb
new file mode 100644
index 0000000000..7a38480f22
--- /dev/null
+++ b/packages/notecase/notecase_1.2.6.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "NoteCase is a hierarchical note manager (aka. outliner)." "
+LICENSE = "BSD"
+
+DEPENDS = "zlib gtk+ gnome-vfs"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}_src.tar.gz \
+ file://no-hardcoded-cxx.patch;patch=1"
+
+inherit pkgconfig
+
+do_compile_prepend() {
+ cp ${STAGING_LIBDIR}/libz.a ${S}/src/lib/zlib/
+}
+
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -m 644 ${S}/docs/notecase.desktop ${D}${datadir}/applications
+ install -m 755 ${S}/bin/notecase ${D}${bindir}/
+}