summaryrefslogtreecommitdiff
path: root/packages/nonworking
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nonworking')
-rw-r--r--packages/nonworking/angstrom/angstrom-e-image.bb8
-rw-r--r--packages/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb2
-rw-r--r--packages/nonworking/ode/.mtn2git_empty0
-rw-r--r--packages/nonworking/ode/files/.mtn2git_empty0
-rw-r--r--packages/nonworking/ode/files/config.h48
-rw-r--r--packages/nonworking/ode/ode_0.8.bb30
-rw-r--r--packages/nonworking/python/python-pyode_1.2.0.bb17
-rw-r--r--packages/nonworking/zethereal/zethereal_1.0.0.bb2
8 files changed, 98 insertions, 9 deletions
diff --git a/packages/nonworking/angstrom/angstrom-e-image.bb b/packages/nonworking/angstrom/angstrom-e-image.bb
index 6db89788ce..b7fdd8e50a 100644
--- a/packages/nonworking/angstrom/angstrom-e-image.bb
+++ b/packages/nonworking/angstrom/angstrom-e-image.bb
@@ -1,7 +1,4 @@
#Angstrom e image
-LICENSE = "MIT"
-PR = "r1"
-
PREFERRED_PROVIDER_virtual/evas ?= "evas-x11"
PREFERRED_PROVIDER_virtual/ecore ?= "ecore-x11"
@@ -19,7 +16,7 @@ XSERVER ?= "xserver-kdrive-fbdev"
export IMAGE_BASENAME = "e-image"
DEPENDS = "task-base"
-RDEPENDS = "\
+IMAGE_INSTALL = "\
${XSERVER} \
task-base-extended \
angstrom-e-base-depends \
@@ -27,9 +24,6 @@ RDEPENDS = "\
angstrom-gpe-task-settings \
${ANGSTROM_EXTRA_INSTALL}"
-
-export PACKAGE_INSTALL = "${RDEPENDS}"
-
#zap root password for release images
ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
diff --git a/packages/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb b/packages/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb
index d93fc7f217..0c9b49755e 100644
--- a/packages/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb
+++ b/packages/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb
@@ -11,7 +11,7 @@ S = "${WORKDIR}/gnuboy"
FILES = ""
FILES_${PN} = "${palmtopdir}/"
-inherit qmake-base
+inherit qmake_base
qtopiadir = "${S}/gnuboy-${PV}-qtopia2"
diff --git a/packages/nonworking/ode/.mtn2git_empty b/packages/nonworking/ode/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/ode/.mtn2git_empty
diff --git a/packages/nonworking/ode/files/.mtn2git_empty b/packages/nonworking/ode/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/ode/files/.mtn2git_empty
diff --git a/packages/nonworking/ode/files/config.h b/packages/nonworking/ode/files/config.h
new file mode 100644
index 0000000000..8711bd91b2
--- /dev/null
+++ b/packages/nonworking/ode/files/config.h
@@ -0,0 +1,48 @@
+/* per-machine configuration. this file is automatically generated. */
+
+#ifndef _ODE_CONFIG_H_
+#define _ODE_CONFIG_H_
+
+/* standard system headers */
+#include <stdio.h>
+#include <stdlib.h>
+#include <math.h>
+#include <string.h>
+#include <stdarg.h>
+#include <malloc.h>
+#include <alloca.h>
+#include <values.h>
+#include <float.h>
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+/* is this a pentium on a gcc-based platform? */
+#undef PENTIUM
+
+/* integer types (we assume int >= 32 bits) */
+typedef char int8;
+typedef unsigned char uint8;
+typedef short int16;
+typedef unsigned short uint16;
+typedef int int32;
+typedef unsigned int uint32;
+
+/* an integer type that we can safely cast a pointer to and
+ * from without loss of bits.
+ */
+typedef unsigned int intP;
+
+/* select the base floating point type */
+#define dDOUBLE 1
+
+/* the floating point infinity */
+#define dInfinity DBL_MAX
+
+/* available functions */
+
+#ifdef __cplusplus
+}
+#endif
+#endif
diff --git a/packages/nonworking/ode/ode_0.8.bb b/packages/nonworking/ode/ode_0.8.bb
new file mode 100644
index 0000000000..9055681a36
--- /dev/null
+++ b/packages/nonworking/ode/ode_0.8.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "ODE is an Open Source Physics Engine."
+SECTION = "libs"
+HOMEPAGE = "http://www.ode.org"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-src-${PV}.zip \
+ file://config.h"
+
+inherit autotools
+
+#do_configure() {
+# touch configurator.exe
+# chmod a+rx configurator.exe
+# install -m 0644 ${WORKDIR}/config.h include/ode/
+#}
+
+#do_compile() {
+# oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}" RANLIB="${RANLIB}" AR="${AR} qf " ode-lib
+#}
+
+#do_stage() {
+# install -d ${STAGING_INCDIR}/ode/
+# install -m 0644 include/ode/*.h ${STAGING_INCDIR}/ode/
+# oe_libinstall -C lib -a libode ${STAGING_LIBDIR}
+#}
+
+#do_install() {
+# :
+#}
diff --git a/packages/nonworking/python/python-pyode_1.2.0.bb b/packages/nonworking/python/python-pyode_1.2.0.bb
new file mode 100644
index 0000000000..95dc0228e3
--- /dev/null
+++ b/packages/nonworking/python/python-pyode_1.2.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "PyODE is a set of open-source Python bindings for The Open Dynamics Engine, \
+an open-source physics engine. PyODE also includes an XODE parser."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "ode"
+SRCNAME = "PyODE"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pyode/${SRCNAME}-${PV}.tar.bz2"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ ln -s ${STAGING_LIBDIR}/.. ../ode
+}
+
diff --git a/packages/nonworking/zethereal/zethereal_1.0.0.bb b/packages/nonworking/zethereal/zethereal_1.0.0.bb
index de4830cb64..74913c1b01 100644
--- a/packages/nonworking/zethereal/zethereal_1.0.0.bb
+++ b/packages/nonworking/zethereal/zethereal_1.0.0.bb
@@ -9,7 +9,7 @@ APPTYPE = "binary"
APPDESKTOP = "${WORKDIR}"
PR = "r0"
-inherit autotools qmake-base
+inherit autotools qmake_base
EXTRA_OECONF = "--disable-ethereal \
--enable-tethereal \