summaryrefslogtreecommitdiff
path: root/packages/nonworking/efl/esmart
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nonworking/efl/esmart')
-rw-r--r--packages/nonworking/efl/esmart/.mtn2git_empty0
-rw-r--r--packages/nonworking/efl/esmart/compile-fix.patch16
-rw-r--r--packages/nonworking/efl/esmart/disable-x-only-features.patch25
-rw-r--r--packages/nonworking/efl/esmart/ecore-fix.patch10
-rw-r--r--packages/nonworking/efl/esmart/include-stdio.patch22
5 files changed, 73 insertions, 0 deletions
diff --git a/packages/nonworking/efl/esmart/.mtn2git_empty b/packages/nonworking/efl/esmart/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/efl/esmart/.mtn2git_empty
diff --git a/packages/nonworking/efl/esmart/compile-fix.patch b/packages/nonworking/efl/esmart/compile-fix.patch
new file mode 100644
index 0000000000..08ca835aa7
--- /dev/null
+++ b/packages/nonworking/efl/esmart/compile-fix.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- esmart-0.9.0.004/src/lib/esmart_container/esmart_container.c~compile-fix
++++ esmart-0.9.0.004/src/lib/esmart_container/esmart_container.c
+@@ -30,7 +30,7 @@
+ return _sort_func(o, oo);
+ }
+
+-void esmart_container_sort(Evas_Object *container, int (*func)(Evas_Object *, Evas_Object *$))
++void esmart_container_sort(Evas_Object *container, int (*func)(Evas_Object *, Evas_Object *))
+ {
+ Container *cont;
+
diff --git a/packages/nonworking/efl/esmart/disable-x-only-features.patch b/packages/nonworking/efl/esmart/disable-x-only-features.patch
new file mode 100644
index 0000000000..68dd363f74
--- /dev/null
+++ b/packages/nonworking/efl/esmart/disable-x-only-features.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- esmart-0.9.0.007/src/lib/Makefile.am~disable-x-only-features.patch
++++ esmart-0.9.0.007/src/lib/Makefile.am
+@@ -1,9 +1,7 @@
+ SUBDIRS = \
+ esmart_container \
+- esmart_draggies \
+ esmart_text_entry \
+ esmart_file_dialog \
+- esmart_thumb \
+- esmart_trans_x11
++ esmart_thumb
+
+ # esmart_textarea
+--- esmart-0.9.0.007/src/Makefile.am~disable-x-only-features.patch
++++ esmart-0.9.0.007/src/Makefile.am
+@@ -1,3 +1,3 @@
+ MAINTAINERCLEANFILES = Makefile.in
+
+-SUBDIRS = lib bin
++SUBDIRS = lib
diff --git a/packages/nonworking/efl/esmart/ecore-fix.patch b/packages/nonworking/efl/esmart/ecore-fix.patch
new file mode 100644
index 0000000000..94deff0b95
--- /dev/null
+++ b/packages/nonworking/efl/esmart/ecore-fix.patch
@@ -0,0 +1,10 @@
+--- esmart-0.9.0.004/src/lib/esmart_trans_x11/esmart_trans_x11.c~ 2004-11-10 07:18:23.000000000 -0800
++++ esmart-0.9.0.004/src/lib/esmart_trans_x11/esmart_trans_x11.c 2005-09-29 11:22:52.000000000 -0700
+@@ -9,6 +9,7 @@
+ #include <X11/Xlib.h>
+ #include <Imlib2.h>
+ #include <Ecore.h>
++#include <Ecore_Data.h>
+ #include <Ecore_X.h>
+ #include <assert.h>
+
diff --git a/packages/nonworking/efl/esmart/include-stdio.patch b/packages/nonworking/efl/esmart/include-stdio.patch
new file mode 100644
index 0000000000..20a490f421
--- /dev/null
+++ b/packages/nonworking/efl/esmart/include-stdio.patch
@@ -0,0 +1,22 @@
+diff -Nur esmart-0.9.0.004~/src/bin/esmart_file_dialog_test.c esmart-0.9.0.004/src/bin/esmart_file_dialog_test.c
+--- esmart-0.9.0.004~/src/bin/esmart_file_dialog_test.c 2005-09-29 14:33:09.000000000 -0700
++++ esmart-0.9.0.004/src/bin/esmart_file_dialog_test.c 2005-09-29 14:33:48.000000000 -0700
+@@ -8,6 +8,7 @@
+ * $ esmart_file_dialog_test /path/to/my_custom/theme.eet
+ * to test a custom theme you've written for it
+ */
++#include <stdio.h>
+ #include <Ecore.h>
+ #include <Edje.h>
+ #include <Ecore_Evas.h>
+diff -Nur esmart-0.9.0.004~/src/lib/esmart_trans_x11/esmart_trans_x11.c esmart-0.9.0.004/src/lib/esmart_trans_x11/esmart_trans_x11.c
+--- esmart-0.9.0.004~/src/lib/esmart_trans_x11/esmart_trans_x11.c 2005-09-29 14:33:09.000000000 -0700
++++ esmart-0.9.0.004/src/lib/esmart_trans_x11/esmart_trans_x11.c 2005-09-29 14:33:19.000000000 -0700
+@@ -4,6 +4,7 @@
+ *
+ ***************************************************************************/
+
++#include <stdio.h>
+ #include <stdlib.h>
+ #include "config.h"
+ #include <X11/Xlib.h>