summaryrefslogtreecommitdiff
path: root/packages/meta/meta-sdl.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/meta/meta-sdl.bb')
-rw-r--r--packages/meta/meta-sdl.bb20
1 files changed, 5 insertions, 15 deletions
diff --git a/packages/meta/meta-sdl.bb b/packages/meta/meta-sdl.bb
index c631fa44c1..76fa01f069 100644
--- a/packages/meta/meta-sdl.bb
+++ b/packages/meta/meta-sdl.bb
@@ -5,22 +5,12 @@ PR = "r1"
ALLOW_EMPTY = 1
-# no need to add libsdl as all libsdl-* already (r)depend on it
-task-sdl-libs = "libsdl-gfx libsdl-image libsdl-mixer libsdl-ttf libsdl-net"
-task-sdl-base = ""
+# no need to add libsdl as all libsdl-* already rdepend on it
+RDEPENDS_task-sdl-libs = "libsdl-gfx libsdl-image libsdl-mixer libsdl-ttf libsdl-net"
-task-sdl-games = "abuse freedroid lbreakout2 openttd prboom quake1 rott supertux xmame"
-task-sdl-emulators = "dgen-sdl e-uae frodo snes9x"
+RDEPENDS_task-sdl-base = ""
+RDEPENDS_task-sdl-games = "abuse freedroid lbreakout2 openttd prboom quake1 rott supertux xmame"
-RDEPENDS_task-sdl-libs = "${task-sdl-libs}"
-DEPENDS += "${task-sdl-libs}"
+RDEPENDS_task-sdl-emulators = "dgen-sdl e-uae frodo snes9x"
-RDEPENDS_task-sdl-base = "${task-sdl-base}"
-DEPENDS += "${task-sdl-base}"
-
-RDEPENDS_task-sdl-games = "${task-sdl-games}"
-DEPENDS += "${task-sdl-games}"
-
-RDEPENDS_task-sdl-emulators = "${task-sdl-emulators}"
-DEPENDS += "${task-sdl-emulators}"