summaryrefslogtreecommitdiff
path: root/packages/lirc/lirc_0.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/lirc/lirc_0.7.0.bb')
-rw-r--r--packages/lirc/lirc_0.7.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/lirc/lirc_0.7.0.bb b/packages/lirc/lirc_0.7.0.bb
index e69de29bb2..eb062770bc 100644
--- a/packages/lirc/lirc_0.7.0.bb
+++ b/packages/lirc/lirc_0.7.0.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \
+ file://split-hauppauge.patch;patch=1 \
+ file://lircd.init file://lircmd.init"
+S = "${WORKDIR}/lirc-${PV}"
+
+inherit autotools module-base update-rc.d
+
+INITSCRIPT_NAME = "lirc"
+INITSCRIPT_PARAMS = "defaults 20"
+
+EXTRA_OECONF_epia = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=serial"
+EXTRA_OECONF_collie = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_h3600 = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_beagle = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_simpad = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+
+EXTRA_OEMAKE = 'SUBDIRS="daemons tools"'
+
+do_stage() {
+ oe_libinstall -so -C tools liblirc_client ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/lirc/
+ install -m 0644 tools/lirc_client.h ${STAGING_INCDIR}/lirc/
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install ${WORKDIR}/lircd.init ${D}/${sysconfdir}/init.d/lircd
+
+ install -d ${D}${datadir}/lirc/
+ cp -a ${S}/remotes ${D}${datadir}/lirc/
+}
+