summaryrefslogtreecommitdiff
path: root/packages/linux/linux_2.6.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux_2.6.21.bb')
-rw-r--r--packages/linux/linux_2.6.21.bb25
1 files changed, 23 insertions, 2 deletions
diff --git a/packages/linux/linux_2.6.21.bb b/packages/linux/linux_2.6.21.bb
index c608fe3378..24d4018de2 100644
--- a/packages/linux/linux_2.6.21.bb
+++ b/packages/linux/linux_2.6.21.bb
@@ -1,7 +1,15 @@
DESCRIPTION = "Linux Kernel"
SECTION = "kernel"
LICENSE = "GPL"
-DEPENDS_kb9202 = "u-boot"
+
+# These devices need mkimage to generate a kernel image
+DEPENDS_kb9202 = "u-boot-mkimage-gta01-native"
+DEPENDS_at32stk1000 = "u-boot-mkimage-gta01-native"
+DEPENDS_atngw100 = "u-boot-mkimage-gta01-native"
+DEPENDS_at91sam9263ek = "u-boot-mkimage-gta01-native"
+
+DEFAULT_PREFERENCE_at91sam9263ek = "-1"
+
PR = "r3"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
@@ -15,14 +23,17 @@ SRC_URI_append_simpad = "\
file://linux-2.6.21-SIMpad-ucb1x00-switches.patch;patch=1 \
file://linux-2.6.21-pcmcia-device-to-platform-driver.patch;patch=1 \
"
-SRC_URI_append_kb9202 = "http://maxim.org.za/AT91RM9200/2.6/2.6.21-at91.patch.gz;patch=1"
+SRC_URI_append_kb9202 = " http://maxim.org.za/AT91RM9200/2.6/2.6.21-at91.patch.gz;patch=1 "
+SRC_URI_append_at91sam9263ek = " http://maxim.org.za/AT91RM9200/2.6/2.6.21-at91.patch.gz;patch=1 "
inherit kernel
KERNEL_IMAGETYPE_progear = "bzImage"
KERNEL_IMAGETYPE_simpad = "zImage"
KERNEL_IMAGETYPE_kb9202 = "uImage"
+KERNEL_IMAGETYPE_atngw100 = "uImage"
KERNEL_IMAGETYPE_at32stk1000 = "uImage"
+KERNEL_IMAGETYPE_at91sam9263ek = "uImage"
do_configure_prepend() {
if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibcgnueabi" ]; then
@@ -40,3 +51,13 @@ do_configure_prepend() {
yes '' | oe_runmake oldconfig
}
+do_install_prepend() {
+ if test -e arch/${ARCH}/boot/Image ; then
+ ln -f arch/arm/boot/Image arch/arm/boot/uImage
+ fi
+
+ if test -e arch/${ARCH}/boot/images/uImage ; then
+ ln -f arch/arm/boot/images/uImage arch/arm/boot/uImage
+ fi
+}
+