summaryrefslogtreecommitdiff
path: root/packages/linux/linux-wrt-2.4.20/gcc_mtune.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/linux-wrt-2.4.20/gcc_mtune.patch')
-rw-r--r--packages/linux/linux-wrt-2.4.20/gcc_mtune.patch69
1 files changed, 0 insertions, 69 deletions
diff --git a/packages/linux/linux-wrt-2.4.20/gcc_mtune.patch b/packages/linux/linux-wrt-2.4.20/gcc_mtune.patch
deleted file mode 100644
index db8b5a7305..0000000000
--- a/packages/linux/linux-wrt-2.4.20/gcc_mtune.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- linux-2.4.20/arch/mips/Makefile~gcc_mtune 2005-01-07 04:06:12.000000000 -0500
-+++ linux-2.4.20/arch/mips/Makefile 2005-01-07 04:07:03.532480104 -0500
-@@ -54,47 +54,47 @@
- # CPU-dependent compiler/assembler options for optimization.
- #
- ifdef CONFIG_CPU_R3000
--GCCFLAGS += -mcpu=r3000 -mips1
-+GCCFLAGS += -mtune=r3000 -mips1
- endif
- ifdef CONFIG_CPU_TX39XX
--GCCFLAGS += -mcpu=r3000 -mips1
-+GCCFLAGS += -mtune=r3000 -mips1
- endif
- ifdef CONFIG_CPU_R6000
--GCCFLAGS += -mcpu=r6000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r6000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_R4300
--GCCFLAGS += -mcpu=r4300 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4300 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_VR41XX
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_R4X00
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_TX49XX
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_MIPS32
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_MIPS64
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_R5000
--GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r5000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_R5432
--GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r5000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_NEVADA
- # Cannot use -mmad with currently recommended tools
--GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r5000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_RM7000
--GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r5000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_SB1
--GCCFLAGS += $(call check_gcc, -mcpu=sb1, -mcpu=r5000) \
-+GCCFLAGS += $(call check_gcc, -mtune=sb1, -mtune=r5000) \
- -mips2 -Wa,--trap
- ifdef CONFIG_SB1_PASS_1_WORKAROUNDS
- MODFLAGS += -msb1-pass1-workarounds