summaryrefslogtreecommitdiff
path: root/packages/linux/linux-wrt-2.4.20/gcc_mtune.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/linux/linux-wrt-2.4.20/gcc_mtune.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/linux/linux-wrt-2.4.20/gcc_mtune.patch')
-rw-r--r--packages/linux/linux-wrt-2.4.20/gcc_mtune.patch69
1 files changed, 0 insertions, 69 deletions
diff --git a/packages/linux/linux-wrt-2.4.20/gcc_mtune.patch b/packages/linux/linux-wrt-2.4.20/gcc_mtune.patch
deleted file mode 100644
index db8b5a7305..0000000000
--- a/packages/linux/linux-wrt-2.4.20/gcc_mtune.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- linux-2.4.20/arch/mips/Makefile~gcc_mtune 2005-01-07 04:06:12.000000000 -0500
-+++ linux-2.4.20/arch/mips/Makefile 2005-01-07 04:07:03.532480104 -0500
-@@ -54,47 +54,47 @@
- # CPU-dependent compiler/assembler options for optimization.
- #
- ifdef CONFIG_CPU_R3000
--GCCFLAGS += -mcpu=r3000 -mips1
-+GCCFLAGS += -mtune=r3000 -mips1
- endif
- ifdef CONFIG_CPU_TX39XX
--GCCFLAGS += -mcpu=r3000 -mips1
-+GCCFLAGS += -mtune=r3000 -mips1
- endif
- ifdef CONFIG_CPU_R6000
--GCCFLAGS += -mcpu=r6000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r6000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_R4300
--GCCFLAGS += -mcpu=r4300 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4300 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_VR41XX
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_R4X00
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_TX49XX
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_MIPS32
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_MIPS64
--GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r4600 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_R5000
--GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r5000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_R5432
--GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r5000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_NEVADA
- # Cannot use -mmad with currently recommended tools
--GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r5000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_RM7000
--GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
-+GCCFLAGS += -mtune=r5000 -mips2 -Wa,--trap
- endif
- ifdef CONFIG_CPU_SB1
--GCCFLAGS += $(call check_gcc, -mcpu=sb1, -mcpu=r5000) \
-+GCCFLAGS += $(call check_gcc, -mtune=sb1, -mtune=r5000) \
- -mips2 -Wa,--trap
- ifdef CONFIG_SB1_PASS_1_WORKAROUNDS
- MODFLAGS += -msb1-pass1-workarounds