summaryrefslogtreecommitdiff
path: root/packages/hostap
diff options
context:
space:
mode:
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/hostap-daemon-0.5.10/.mtn2git_empty (renamed from packages/hostap/hostap-daemon-0.6.3/.mtn2git_empty)0
-rw-r--r--packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff (renamed from packages/hostap/hostap-daemon-0.6.3/makefile-cross.diff)20
-rw-r--r--packages/hostap/hostap-daemon-0.6.3/init37
-rw-r--r--packages/hostap/hostap-daemon/init24
-rw-r--r--packages/hostap/hostap-daemon_0.5.1.bb5
-rw-r--r--packages/hostap/hostap-daemon_0.5.10.bb (renamed from packages/hostap/hostap-daemon_0.6.3.bb)8
6 files changed, 29 insertions, 65 deletions
diff --git a/packages/hostap/hostap-daemon-0.6.3/.mtn2git_empty b/packages/hostap/hostap-daemon-0.5.10/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/hostap/hostap-daemon-0.6.3/.mtn2git_empty
+++ b/packages/hostap/hostap-daemon-0.5.10/.mtn2git_empty
diff --git a/packages/hostap/hostap-daemon-0.6.3/makefile-cross.diff b/packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff
index 9534199e78..43b275c67b 100644
--- a/packages/hostap/hostap-daemon-0.6.3/makefile-cross.diff
+++ b/packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff
@@ -1,7 +1,13 @@
-diff -urN hostapd.orig/Makefile hostapd/Makefile
---- hostapd.orig/Makefile 2007-05-28 19:26:55.000000000 +0200
-+++ hostapd/Makefile 2007-11-22 16:28:44.000000000 +0100
-@@ -6,6 +6,8 @@
+diff -urN hostapd-0.5.10.orig/Makefile hostapd-0.5.10/Makefile
+--- hostapd-0.5.10.orig/Makefile 2008-02-20 01:08:54.000000000 +0100
++++ hostapd-0.5.10/Makefile 2008-04-28 17:01:36.000000000 +0200
+@@ -1,10 +1,14 @@
++ifndef CC
+ CC=gcc
++endif
+ DIR_WPA_SUPPLICANT=.
+
+ ifndef CFLAGS
CFLAGS = -MMD -O2 -Wall -g
endif
@@ -10,7 +16,7 @@ diff -urN hostapd.orig/Makefile hostapd/Makefile
# define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
# a file (undefine it, if you want to save in binary size)
CFLAGS += -DHOSTAPD_DUMP_STATE
-@@ -361,10 +363,10 @@
+@@ -333,10 +337,10 @@
fi
install: all
@@ -21,5 +27,5 @@ diff -urN hostapd.orig/Makefile hostapd/Makefile
- $(CC) -o hostapd $(OBJS) $(LIBS)
+ $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
- OBJS_c = hostapd_cli.o ../src/common/wpa_ctrl.o ../src/utils/os_$(CONFIG_OS).o
- hostapd_cli: $(OBJS_c)
+ driver_conf.c: Makefile .config
+ rm -f driver_conf.c
diff --git a/packages/hostap/hostap-daemon-0.6.3/init b/packages/hostap/hostap-daemon-0.6.3/init
deleted file mode 100644
index 79f74b681e..0000000000
--- a/packages/hostap/hostap-daemon-0.6.3/init
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-DAEMON=/usr/sbin/hostapd
-NAME=hostapd
-DESC="HOSTAP Daemon"
-ARGS="/etc/hostapd.conf -B"
-
-test -f $DAEMON || exit 0
-
-set -e
-
-case "$1" in
- start)
- echo -n "Starting $DESC: "
- start-stop-daemon -S -x $DAEMON -- $ARGS
- echo "$NAME."
- ;;
- stop)
- echo -n "Stopping $DESC: "
- start-stop-daemon -K -x $DAEMON
- echo "$NAME."
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- reload)
- echo -n "Reloading $DESC: "
- killall -HUP $(basename ${DAEMON})
- echo "$NAME."
- ;;
- *)
- echo "Usage: $0 {start|stop|restart|reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/hostap/hostap-daemon/init b/packages/hostap/hostap-daemon/init
index ed4c9de1a9..79f74b681e 100644
--- a/packages/hostap/hostap-daemon/init
+++ b/packages/hostap/hostap-daemon/init
@@ -2,7 +2,7 @@
DAEMON=/usr/sbin/hostapd
NAME=hostapd
DESC="HOSTAP Daemon"
-ARGS="/etc/hostapd.conf"
+ARGS="/etc/hostapd.conf -B"
test -f $DAEMON || exit 0
@@ -10,25 +10,23 @@ set -e
case "$1" in
start)
- echo -n "starting $DESC: $NAME... "
- start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS
- echo "done."
+ echo -n "Starting $DESC: "
+ start-stop-daemon -S -x $DAEMON -- $ARGS
+ echo "$NAME."
;;
stop)
- echo -n "stopping $DESC: $NAME... "
- start-stop-daemon -K -n $NAME
- echo "done."
+ echo -n "Stopping $DESC: "
+ start-stop-daemon -K -x $DAEMON
+ echo "$NAME."
;;
restart)
- echo "restarting $DESC: $NAME... "
- $0 stop
+ $0 stop
$0 start
- echo "done."
;;
reload)
- echo -n "reloading $DESC: $NAME... "
- killall -HUP $(basename ${DAEMON})
- echo "done."
+ echo -n "Reloading $DESC: "
+ killall -HUP $(basename ${DAEMON})
+ echo "$NAME."
;;
*)
echo "Usage: $0 {start|stop|restart|reload}"
diff --git a/packages/hostap/hostap-daemon_0.5.1.bb b/packages/hostap/hostap-daemon_0.5.1.bb
deleted file mode 100644
index de3abdbea5..0000000000
--- a/packages/hostap/hostap-daemon_0.5.1.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require hostap-daemon.inc
-
-PR = "r1"
-
-DEFAULT_PREFERENCE = "-1"
diff --git a/packages/hostap/hostap-daemon_0.6.3.bb b/packages/hostap/hostap-daemon_0.5.10.bb
index 37b710db19..f75efc4a34 100644
--- a/packages/hostap/hostap-daemon_0.6.3.bb
+++ b/packages/hostap/hostap-daemon_0.5.10.bb
@@ -5,14 +5,16 @@ PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
-DEFAULT_PREFERENCE = "-1"
+#we introduce MY_ARCH to get 'armv5te' as arch instead of the misleading 'arm' on armv5te builds
+MY_ARCH := "${PACKAGE_ARCH}"
+PACKAGE_ARCH = "${@base_contains('COMBINED_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}', d)}"
SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
file://makefile-cross.diff;patch=1 \
file://defconfig \
file://init"
-S = "${WORKDIR}/hostapd-${PV}/hostapd"
+S = "${WORKDIR}/hostapd-${PV}"
export HAS_PCI = "${@base_contains('COMBINED_FEATURES', 'pci', 1, 0,d)}"
@@ -28,7 +30,7 @@ do_configure() {
}
do_compile() {
- CFLAGS='${CFLAGS}' CC='${CC}' make
+ make
}
do_install() {