summaryrefslogtreecommitdiff
path: root/packages/hal/files
diff options
context:
space:
mode:
Diffstat (limited to 'packages/hal/files')
-rw-r--r--packages/hal/files/20hal4
-rw-r--r--packages/hal/files/autoconf.diff11
-rw-r--r--packages/hal/files/sg-inhibit.patch24
3 files changed, 37 insertions, 2 deletions
diff --git a/packages/hal/files/20hal b/packages/hal/files/20hal
index 834e51afc0..5b97c4f9e6 100644
--- a/packages/hal/files/20hal
+++ b/packages/hal/files/20hal
@@ -12,7 +12,7 @@
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/hald
PIDDIR=/var/run/hald
-PIDFILE=$PIDDIR/pid
+PIDFILE=$PIDDIR/hald.pid
NAME=hald
DAEMONUSER=haldaemon
DESC="Hardware abstraction layer"
@@ -33,7 +33,7 @@ do_start() {
do_stop() {
echo "Stopping $DESC" "$NAME"
- start-stop-daemon --stop --oknodo --quiet --pidfile $PIDFILE \
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
--exec $DAEMON
}
diff --git a/packages/hal/files/autoconf.diff b/packages/hal/files/autoconf.diff
new file mode 100644
index 0000000000..eb30cccdbe
--- /dev/null
+++ b/packages/hal/files/autoconf.diff
@@ -0,0 +1,11 @@
+--- hal-0.5.9/configure.in~ 2007-04-03 05:36:44.000000000 +0100
++++ hal-0.5.9/configure.in 2007-04-03 10:29:39.000000000 +0100
+@@ -6,7 +6,7 @@
+ # Patches for that is welcome.
+ #
+
+-AC_PREREQ(2.59c)
++AC_PREREQ(2.59)
+ AC_INIT(hal, 0.5.9, david@fubar.dk)
+ AM_INIT_AUTOMAKE(hal, 0.5.9)
+ AM_CONFIG_HEADER(config.h)
diff --git a/packages/hal/files/sg-inhibit.patch b/packages/hal/files/sg-inhibit.patch
new file mode 100644
index 0000000000..f0cc41448a
--- /dev/null
+++ b/packages/hal/files/sg-inhibit.patch
@@ -0,0 +1,24 @@
+--- hal-0.5.9.1/hald/linux/probing/linux_dvd_rw_utils.c.old 2007-08-03 17:24:12.000000000 +0100
++++ hal-0.5.9.1/hald/linux/probing/linux_dvd_rw_utils.c 2007-08-03 17:25:06.000000000 +0100
+@@ -58,6 +58,10 @@
+
+ #include "linux_dvd_rw_utils.h"
+
++#if defined(SG_FLAG_UNUSED_LUN_INHIBIT)
++# define SG_FLAG_LUN_INHIBIT SG_FLAG_UNUSED_LUN_INHIBIT
++#endif
++
+ typedef enum {
+ NONE = CGC_DATA_NONE, // 3
+ READ = CGC_DATA_READ, // 2
+@@ -153,8 +153,8 @@
+ errno = EIO;
+ ret = -1;
+ if (cmd->sg_io.masked_status & CHECK_CONDITION) {
+- CREAM_ON_ERRNO (cmd->sg_io.sbp);
+- ret = ERRCODE (cmd->sg_io.sbp);
++ CREAM_ON_ERRNO ((char*)cmd->sg_io.sbp);
++ ret = ERRCODE ((char*)cmd->sg_io.sbp);
+ if (ret == 0)
+ ret = -1;
+ }