summaryrefslogtreecommitdiff
path: root/packages/gettext/gettext-native_0.14.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gettext/gettext-native_0.14.1.bb')
-rw-r--r--packages/gettext/gettext-native_0.14.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/gettext/gettext-native_0.14.1.bb b/packages/gettext/gettext-native_0.14.1.bb
index 6203b1f9d7..f792f3247a 100644
--- a/packages/gettext/gettext-native_0.14.1.bb
+++ b/packages/gettext/gettext-native_0.14.1.bb
@@ -2,6 +2,7 @@ require gettext_${PV}.bb
S = "${WORKDIR}/gettext-${PV}"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gettext-${PV}"
inherit native
+DEPENDS = ""
PROVIDES = ""
M4 = "\
@@ -50,4 +51,10 @@ do_stage_append() {
fi
install -m 0644 $src ${STAGING_DATADIR}/aclocal/$i
done
+ # config.rpath is needed by some configure macros and needs to be autoinstalled.
+ # automake will do this but config.rpath needs to be visible to automake
+ for i in `ls -d ${STAGING_DATADIR}/automake*`
+ do
+ cp ${STAGING_DATADIR}/gettext/config.rpath $i
+ done
}