summaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-cross-initial_4.3.1.bb6
-rw-r--r--packages/gcc/gcc-cross-initial_4.3.2.bb6
-rw-r--r--packages/gcc/gcc-cross-intermediate_4.3.1.bb6
-rw-r--r--packages/gcc/gcc-cross-intermediate_4.3.2.bb6
-rw-r--r--packages/gcc/gcc-cross_4.3.1.bb8
-rw-r--r--packages/gcc/gcc-cross_4.3.2.bb8
6 files changed, 2 insertions, 38 deletions
diff --git a/packages/gcc/gcc-cross-initial_4.3.1.bb b/packages/gcc/gcc-cross-initial_4.3.1.bb
index 3858d8813b..067ab61be3 100644
--- a/packages/gcc/gcc-cross-initial_4.3.1.bb
+++ b/packages/gcc/gcc-cross-initial_4.3.1.bb
@@ -7,9 +7,3 @@ EXTRA_OECONF += " --disable-libmudflap \
--disable-libgomp \
--enable-decimal-float=no \
--disable-libssp"
-
-# Hack till we fix *libc properly
-do_stage_append() {
- ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
-}
-
diff --git a/packages/gcc/gcc-cross-initial_4.3.2.bb b/packages/gcc/gcc-cross-initial_4.3.2.bb
index 3858d8813b..067ab61be3 100644
--- a/packages/gcc/gcc-cross-initial_4.3.2.bb
+++ b/packages/gcc/gcc-cross-initial_4.3.2.bb
@@ -7,9 +7,3 @@ EXTRA_OECONF += " --disable-libmudflap \
--disable-libgomp \
--enable-decimal-float=no \
--disable-libssp"
-
-# Hack till we fix *libc properly
-do_stage_append() {
- ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
-}
-
diff --git a/packages/gcc/gcc-cross-intermediate_4.3.1.bb b/packages/gcc/gcc-cross-intermediate_4.3.1.bb
index b0932f520d..a9ae5bdf20 100644
--- a/packages/gcc/gcc-cross-intermediate_4.3.1.bb
+++ b/packages/gcc/gcc-cross-intermediate_4.3.1.bb
@@ -6,9 +6,3 @@ DEPENDS += "gmp-native mpfr-native"
EXTRA_OECONF += " --disable-libmudflap \
--disable-libgomp \
--disable-libssp"
-
-# Hack till we fix *libc properly
-do_stage_append() {
- ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
-}
-
diff --git a/packages/gcc/gcc-cross-intermediate_4.3.2.bb b/packages/gcc/gcc-cross-intermediate_4.3.2.bb
index b0932f520d..a9ae5bdf20 100644
--- a/packages/gcc/gcc-cross-intermediate_4.3.2.bb
+++ b/packages/gcc/gcc-cross-intermediate_4.3.2.bb
@@ -6,9 +6,3 @@ DEPENDS += "gmp-native mpfr-native"
EXTRA_OECONF += " --disable-libmudflap \
--disable-libgomp \
--disable-libssp"
-
-# Hack till we fix *libc properly
-do_stage_append() {
- ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
-}
-
diff --git a/packages/gcc/gcc-cross_4.3.1.bb b/packages/gcc/gcc-cross_4.3.1.bb
index 48934f73c5..2b93165d44 100644
--- a/packages/gcc/gcc-cross_4.3.1.bb
+++ b/packages/gcc/gcc-cross_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r13"
+PR = "r14"
require gcc-${PV}.inc
require gcc-cross4.inc
@@ -9,10 +9,4 @@ SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
EXTRA_OECONF += " --enable-cheaders=c_std --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
-# Hack till we fix *libc properly
-do_stage_append() {
- ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
-}
-
-
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"
diff --git a/packages/gcc/gcc-cross_4.3.2.bb b/packages/gcc/gcc-cross_4.3.2.bb
index 7e649ac280..1220f8df0d 100644
--- a/packages/gcc/gcc-cross_4.3.2.bb
+++ b/packages/gcc/gcc-cross_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc
@@ -8,10 +8,4 @@ SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
EXTRA_OECONF += " --enable-cheaders=c_std --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
-# Hack till we fix *libc properly
-do_stage_append() {
- ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
-}
-
-
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"