summaryrefslogtreecommitdiff
path: root/packages/gawk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gawk')
-rw-r--r--packages/gawk/gawk_3.1.4.bb30
1 files changed, 14 insertions, 16 deletions
diff --git a/packages/gawk/gawk_3.1.4.bb b/packages/gawk/gawk_3.1.4.bb
index bf93f7e201..5af890eec8 100644
--- a/packages/gawk/gawk_3.1.4.bb
+++ b/packages/gawk/gawk_3.1.4.bb
@@ -1,29 +1,27 @@
-LICENSE = "GPL"
-SECTION = "interpreters"
DESCRIPTION = "A program that you can use to select particular records in a \
file and perform operations upon them."
-PR = "r2"
-PACKAGES += "gawk-common pgawk"
-FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
-FILES_gawk-common += "${datadir}/awk ${libexecdir}/awk"
-FILES_pgawk = "${bindir}/pgawk*"
+SECTION = "interpreters"
+LICENSE = "GPL"
RDEPENDS_gawk += "gawk-common"
RDEPENDS_pgawk += "gawk-common"
+PR = "r3"
SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz"
-inherit autotools
+inherit autotools update-alternatives
do_configure_prepend () {
- grep -E '^AC_DEFUN' m4/*.m4|grep -E '\(\[?(AM|AC)_'|xargs rm -f
-}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${bindir}/awk awk gawk 100
+ grep -E '^AC_DEFUN' m4/*.m4|grep -E '\(\[?(AM|AC)_'|xargs rm -f
}
+PACKAGES += "gawk-common pgawk"
-pkg_prerm_${PN} () {
- update-alternatives --remove awk gawk
-}
+FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
+FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
+FILES_pgawk = "${bindir}/pgawk*"
+FILES_${PN}-dbg += "${libexecdir}/awk/.debug"
+ALTERNATIVE_NAME = "awk"
+ALTERNATIVE_PATH = "gawk"
+ALTERNATIVE_LINK = "${bindir}/awk"
+ALTERNATIVE_PRIORITY = "100"