summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/fso-abyss/abyss.conf0
-rw-r--r--packages/freesmartphone/fso-abyss/om-gta01/abyss.conf16
-rw-r--r--packages/freesmartphone/fso-abyss/om-gta02/abyss.conf16
-rw-r--r--packages/freesmartphone/fso-abyss/om-gta03/abyss.conf16
-rw-r--r--packages/freesmartphone/fso-abyss_git.bb30
-rw-r--r--packages/freesmartphone/libframeworkd-glib_git.bb9
-rw-r--r--packages/freesmartphone/libgsm0710_git.bb14
7 files changed, 88 insertions, 13 deletions
diff --git a/packages/freesmartphone/fso-abyss/abyss.conf b/packages/freesmartphone/fso-abyss/abyss.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/freesmartphone/fso-abyss/abyss.conf
diff --git a/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf
new file mode 100644
index 0000000000..2ff579d730
--- /dev/null
+++ b/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 1
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
diff --git a/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf
new file mode 100644
index 0000000000..2ff579d730
--- /dev/null
+++ b/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 1
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
diff --git a/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf
new file mode 100644
index 0000000000..1764c5b798
--- /dev/null
+++ b/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 0
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
diff --git a/packages/freesmartphone/fso-abyss_git.bb b/packages/freesmartphone/fso-abyss_git.bb
index 471f404fc1..3cfff7dc9a 100644
--- a/packages/freesmartphone/fso-abyss_git.bb
+++ b/packages/freesmartphone/fso-abyss_git.bb
@@ -2,17 +2,35 @@ DESCRIPTION = "Abyss is a GSM 07.10 muxer userspace daemon"
HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/Abyss"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
SECTION = "console/network"
-DEPENDS = "vala-native dbus dbus-glib libgee"
+DEPENDS = "vala-native dbus dbus-glib libgsm0710"
LICENSE = "GPL"
-PV = "0.2.0+gitr${SRCREV}"
+PV = "0.3.0+gitr${SRCREV}"
PR = "r0"
-SRC_URI = "${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master"
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master \
+ file://abyss.conf \
+"
S = "${WORKDIR}/git"
inherit autotools
-RDEPENDS = "dbus dbus-glib"
-RCONFLICTS = "gsm0710muxd fso-gsm0710muxd"
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/abyss.conf ${D}${sysconfdir}/
+}
-FILES_${PN} += "${datadir} ${sysconfdir}"
+PACKAGES =+ "${PN}-config"
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+RRECOMMENDS_${PN} = "${PN}-config"
+
+FILES_${PN}-config = "\
+ ${sysconfdir}/abyss.conf \
+"
+
+CONFFILES_${PN}-config = "\
+ ${sysconfdir}/abyss.conf \
+"
+
+PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"
diff --git a/packages/freesmartphone/libframeworkd-glib_git.bb b/packages/freesmartphone/libframeworkd-glib_git.bb
index bce8312fcb..79e040ed35 100644
--- a/packages/freesmartphone/libframeworkd-glib_git.bb
+++ b/packages/freesmartphone/libframeworkd-glib_git.bb
@@ -2,15 +2,10 @@ DESCRIPTION = "freesmartphone.org API glib wrapper"
LICENSE = "LGPL"
SECTION = "devel"
DEPENDS = "dbus-glib"
-PV = "0.0.1+gitr${SRCREV}"
+PV = "0.0.2+gitr${SRCREV}"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/libframeworkd-glib.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
-
+inherit autotools autotools_stage pkgconfig
diff --git a/packages/freesmartphone/libgsm0710_git.bb b/packages/freesmartphone/libgsm0710_git.bb
new file mode 100644
index 0000000000..bc4e59ea34
--- /dev/null
+++ b/packages/freesmartphone/libgsm0710_git.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A GSM 07.10 Protocol Engine"
+LICENSE = "GPL"
+SECTION = "devel"
+PV = "1.0.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/libgsm0710.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools autotools_stage pkgconfig
+
+# ship vapi file
+FILES_${PN}-dev += "${datadir}/vala"
+